Bug 1124753 - don't use initV files with systemd
Summary: don't use initV files with systemd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-3.6.0-rc
: 2.0.0
Assignee: Martin Sivák
QA Contact: Nikolai Sednev
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 08:47 UTC by Jiri Moskovcak
Modified: 2016-02-10 19:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-27 07:48:13 UTC
oVirt Team: SLA
rule-engine: ovirt-3.6.0+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)

Description Jiri Moskovcak 2014-07-30 08:47:51 UTC
Description of problem:
it seems to collide with systemd https://bugzilla.redhat.com/show_bug.cgi?id=1123285#c3

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-1.2.1

How reproducible:
100%

Steps to Reproduce:
1. try to install hosted engine on F19
2.
3.

Actual results:
systemctl fails to run the services

Expected results:


Additional info:
I believe that systemctl doesn't react properly to the old status() call which is supposed to return code depending on the state of the service. Or the status() call is not handling the systemd pid/log file logic and returns wrong value.

Comment 2 Sandro Bonazzola 2015-09-29 09:09:15 UTC
This is an automated message.
oVirt 3.6.0 RC1 has been released. This bug has no target release and still have target milestone set to 3.6.0-rc.
Please review this bug and set target milestone and release to one of the next releases.

Comment 3 Doron Fediuck 2015-10-07 06:16:26 UTC
Martin,
is this still relevant?

Comment 4 Martin Sivák 2015-10-07 08:37:46 UTC
I haven't seen this behaviour and we have proper systemd unit files.

Comment 5 Red Hat Bugzilla Rules Engine 2015-10-18 08:34:54 UTC
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.

Comment 6 Nikolai Sednev 2015-11-25 07:54:19 UTC
Works for me on these components:
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-002-2.noarch
ovirt-engine-sdk-python-3.6.0.4-0.2.20151123.gita2f81ed.el7.centos.noarch
sanlock-3.2.4-1.el7.x86_64
ovirt-setup-lib-1.0.1-0.0.master.20151119123055.gitfa908be.el7.centos.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.3.x86_64
ovirt-hosted-engine-ha-1.3.3-0.0.master.20151118145556.20151118145552.git71b535e.el7.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-002-2.noarch
libvirt-client-1.2.17-13.el7.x86_64
ovirt-hosted-engine-setup-1.3.1-0.0.master.20151118143825.gitc013638.el7.centos.noarch
ovirt-host-deploy-1.4.2-0.0.master.20151122153544.gitfc808fc.el7.noarch
vdsm-4.17.10.1-0.el7ev.noarch
mom-0.5.1-2.el7.noarch

Comment 7 Sandro Bonazzola 2015-11-27 07:48:13 UTC
Since oVirt 3.6.0 has been released, moving from verified to closed current release.


Note You need to log in before you can comment on or make changes to this bug.