Bug 1124767 - EAP6 resources which were in discovery queue before plugin update remain down after import due to BZ840403
Summary: EAP6 resources which were in discovery queue before plugin update remain down...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.2.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: post-GA
: One-off release
Assignee: Larry O'Leary
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 1127928
Blocks: 1088652 1112696 1117854 1128960
TreeView+ depends on / blocked
 
Reported: 2014-07-30 09:25 UTC by Filip Brychta
Modified: 2014-08-19 14:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1127928 (view as bug list)
Environment:
Last Closed: 2014-08-19 14:31:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2014-07-30 09:25:29 UTC
Description of problem:
$Summary

Version-Release number of selected component (if applicable):
Version :	
3.2.0.GA Update 02
Build Number :	
dfe3e4b:cf4474c

How reproducible:
2/2

Steps to Reproduce:
1. install jon3.2.2 with agent which is monitoring EAP6
2. make sure that EAP6 resource is visible in discovery queue
3. install jon-plugin-pack-eap-3.2.0.GA-update-01
  a. unzip jon-plugin-pack-eap-3.2.0.GA-update-01.zip
  b. cp plugins/*.jar jon-server-3.2.0.GA/plugins/
  c. go to Administration->Agent Plugins->Scan For Updates
  d. when the scan is done, invoke 'Update All Plugins' operation on relevant agent
  e. import EAP6 resources from discovery queue

Actual results:
Resources are down and following error is visible in agent.log:

2014-07-30 04:05:45,462 WARN  [InventoryManager.availability-1] (rhq.core.pc.inventory.AvailabilityExecutor)- Availability collection failed with exception on Resource[id=10092, uuid=8ab41f8c-fe54-4895-8e40-b4c649f85069, type={JBossAS7}JBossAS7 Host Controller, key=hostConfig: /home/hudson/jboss-eap6-domain/domain/configuration/host-changed.xml, name=EAP Domain Controller (0.0.0.0:8990), parent=fbr-eap6-2.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.2.4.GA], availability will be reported as DOWN
org.rhq.core.clientapi.agent.PluginContainerException: Failed to start component for resource Resource[id=10092, uuid=8ab41f8c-fe54-4895-8e40-b4c649f85069, type={JBossAS7}JBossAS7 Host Controller, key=hostConfig: /home/hudson/jboss-eap6-domain/domain/configuration/host-changed.xml, name=EAP Domain Controller (0.0.0.0:8990), parent=fbr-eap6-2.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.2.4.GA].
	at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1943)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:361)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:429)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.startScan(AvailabilityExecutor.java:195)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.call(AvailabilityExecutor.java:152)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.run(AvailabilityExecutor.java:111)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351)
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:178)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.IllegalArgumentException: name is null
	at org.rhq.modules.plugins.jbossas7.helper.TrustStrategy.findByName(TrustStrategy.java:36)
	at org.rhq.modules.plugins.jbossas7.helper.ServerPluginConfiguration.getTrustStrategy(ServerPluginConfiguration.java:183)
	at org.rhq.modules.plugins.jbossas7.ASConnectionParams.createFrom(ASConnectionParams.java:84)
	at org.rhq.modules.plugins.jbossas7.BaseServerComponent.start(BaseServerComponent.java:108)
	at sun.reflect.GeneratedMethodAccessor45.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocation.call(ResourceContainer.java:654)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	... 3 more

Expected results:
Resources are up without errors

Additional info:
It seems that this issue doesn't affect already imported EAP6 resources (tried that twice).
Workaround: uninventory affected resources and import them again

Comment 2 Thomas Segismont 2014-08-01 10:40:48 UTC
Filip, does this issue apply to SSL protected EAP6 servers only or to all kind of servers?

Comment 3 Filip Brychta 2014-08-01 12:26:27 UTC
It affects all kinds of servers. Easiest way to reproduce is to use RHQ server resource:

2014-08-01 08:23:32,602 ERROR [RHQ Agent Plugin Container Restart Thread] (rhq.core.pc.inventory.InventoryManager)- Exception thrown while activating [Resource[id=10003, uuid=bbae12ff-e7f6-4538-a8ac-5ea89c8971d1, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /home/hudson/jon-server-3.2.0.GA/jbossas/standalone/configuration/standalone-full.xml, name=EAP (127.0.0.1:6990) RHQ Server, parent=fbr-jon322.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.1.1.GA]].
org.rhq.core.clientapi.agent.PluginContainerException: Failed to start component for resource Resource[id=10003, uuid=bbae12ff-e7f6-4538-a8ac-5ea89c8971d1, type={JBossAS7}JBossAS7 Standalone Server, key=hostConfig: /home/hudson/jon-server-3.2.0.GA/jbossas/standalone/configuration/standalone-full.xml, name=EAP (127.0.0.1:6990) RHQ Server, parent=fbr-jon322.bc.jonqe.lab.eng.bos.redhat.com, version=EAP 6.1.1.GA].

Comment 8 Filip Brychta 2014-08-12 09:38:19 UTC
Verified on
Version :	
3.2.0.GA
Build Number :	
dcb8b6f:734bd56

Comment 9 Filip Brychta 2014-08-12 10:57:46 UTC
Verified on
Version :	
3.2.0.GA Update 02
Build Number :	
dfe3e4b:cf4474c

as well


Note You need to log in before you can comment on or make changes to this bug.