Bug 1124771 - Group selection is wiped out when switching environments
Summary: Group selection is wiped out when switching environments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Kolman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 09:34 UTC by Martin Kolman
Modified: 2015-03-05 14:02 UTC (History)
2 users (show)

Fixed In Version: anaconda-19.31.83-1
Doc Type: Bug Fix
Doc Text:
Cause: All groups have been unselected when switching environments on the software spoke. Consequence: If the user selected some groups, his selection would be lost even if the user switched back. Fix: Keep group selection when switching environments and select relevant groups after the switch. Result: Improved user experience as the user does not loose his group selection every time he switches environments.
Clone Of:
Environment:
Last Closed: 2015-03-05 14:02:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0312 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-03-05 17:35:22 UTC

Description Martin Kolman 2014-07-30 09:34:43 UTC
Description of problem:
Any changes made in the group tab in the Anaconda software selection spoke are wiped out if the user switches to another environment. If the user switches back, all groups are again unselected. Also any ticked groups common with the environment the user has switched to are unticked.

This seems to be a serious usability issue - there can be quite a lot of groups that can be selected and we are basically throwing out the users work.

Also once bug 1087831 is fixed the current behavior could result in wiping out group selection from kickstart.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. on the "Installation summary" hub enter the "Software selection" spoke
2. select a few groups in an environment
3. switch to another environment and back to the original one

Actual results:
Any group selection is wiped out when switching environments.

Expected results:
When switching environments the changes made by user should not be silently dropped. Also any common selected groups should remain selected ("ticked") when switching environments.

Additional info:
I actually have a patch fixing this ready to use that was too late for 7.0.

Comment 3 Alexander Todorov 2014-11-24 13:56:43 UTC
(In reply to Martin Kolman from comment #0)

> Steps to Reproduce:
> 1. on the "Installation summary" hub enter the "Software selection" spoke
> 2. select a few groups in an environment
> 3. switch to another environment and back to the original one
> 
> Actual results:
> Any group selection is wiped out when switching environments.

Switching back and forth between environments doesn't change selection of groups.

Comment 5 errata-xmlrpc 2015-03-05 14:02:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html


Note You need to log in before you can comment on or make changes to this bug.