Bug 1124777 - upgrade: for nova upgrade, we refer to updating multiple controller when there is no HA for nova yet
Summary: upgrade: for nova upgrade, we refer to updating multiple controller when ther...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Upgrade
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 6)
Assignee: Don Domingo
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 09:49 UTC by Dafna Ron
Modified: 2015-03-10 03:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-10 03:36:17 UTC


Attachments (Terms of Use)

Description Dafna Ron 2014-07-30 09:49:24 UTC
Description of problem:

In upgrade service by service with live compute upgrade we give instructions for multiple controllers when there is only one controller in a setup (for now). 

for example, the following line: 

1. On each controller node, stop any running nova services: 

controller node = the host we install the AIP and other nova services. and there is only one (HA is not implemented yet)

the document continues the same way and it's confusing since the user might think the document means all computes as well as the controller (leading to wrong commands and stooping services on the computes which would not make it live upgrade any more) 

Version-Release number of selected component (if applicable):

rhos4 -> rhoe5

How reproducible:

100%

Steps to Reproduce:
1. follow: Procedure 2. Upgrading compute controllers
2.
3.

Actual results:

I think that we are not clear in what we call controller and what we call compute and it's really confusing when doing the upgrade. 

Expected results:

compute: a host where the instances are running on and has the nova compute service installed
controller: a host that has nova control services such as AIP 


Additional info:

controller node: 

[root@gizmo ~]# rpm -qa |grep nova
openstack-nova-cert-2013.2.3-5.el6ost.noarch
python-nova-2013.2.3-5.el6ost.noarch
openstack-nova-novncproxy-2013.2.3-5.el6ost.noarch
python-novaclient-2.17.0-2.el6ost.noarch
openstack-nova-console-2013.2.3-5.el6ost.noarch
openstack-nova-compute-2013.2.3-5.el6ost.noarch
openstack-nova-scheduler-2013.2.3-5.el6ost.noarch
openstack-nova-api-2013.2.3-5.el6ost.noarch
openstack-nova-conductor-2013.2.3-5.el6ost.noarch
openstack-nova-common-2013.2.3-5.el6ost.noarch

compute node: 

[root@greta ~]# rpm -qa |grep nova
python-novaclient-2.17.0-2.el6ost.noarch
python-nova-2013.2.3-5.el6ost.noarch
openstack-nova-common-2013.2.3-5.el6ost.noarch
openstack-nova-compute-2013.2.3-5.el6ost.noarch

Comment 1 Andrew Dahms 2014-07-30 21:48:21 UTC
Assigning to Summer Long, as the designated author for Nova.

Comment 5 Summer Long 2014-08-26 04:27:33 UTC
Hi Dafna, the issue is that documents don't use the term 'nova' to mean Compute. Nova is the old project name, or the client, but not the component name; we switched over a couple of versions back (were told to do so by project management).
BTW, the guide has now been split into articles, and all topics are no longer valid. Assigning back to Don, since he's been juggling the content. (aplogies for the back and forth).
cheers, Summer


Note You need to log in before you can comment on or make changes to this bug.