Bug 1124802 - dependency problems on Centos 7
Summary: dependency problems on Centos 7
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 11:09 UTC by Netbulae
Modified: 2014-08-14 09:32 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 10:41:07 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30921 master MERGED Updated EL dependencies repo Never

Description Netbulae 2014-07-30 11:09:38 UTC
When using a fresh Centos 7 install and trying to install vdsm from:

ovirt-3.5-pre/rpm/el7/noarch/ovirt-release35-001-0.2.beta2.noarch.rpm


I get the followind dependency problems:

--> Processing Dependency: python(abi) = 2.6 for package: mom-0.4.1-2.el6.noarch
---> Package perl-Business-ISBN-Data.noarch 0:20120719.001-2.el7 will be installed
---> Package perl-IO-Socket-IP.noarch 0:0.21-4.el7 will be installed
---> Package perl-Net-LibIDN.x86_64 0:0.12-15.el7 will be installed
---> Package perl-Net-SSLeay.x86_64 0:1.55-3.el7 will be installed
---> Package python-cpopen.x86_64 0:1.3-1.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: python-cpopen-1.3-1.el6.x86_64
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: python-cpopen-1.3-1.el6.x86_64
---> Package python-pthreading.noarch 0:0.1.3-3.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: python-pthreading-0.1.3-3.el6.noarch
---> Package vdsm.x86_64 0:4.16.1-0.gita4d9abf.el7 will be installed
--> Processing Dependency: python-ioprocess >= 0.5-1 for package: vdsm-4.16.1-0.gita4d9abf.el7.x86_64
---> Package vdsm-python.x86_64 0:4.16.1-0.gita4d9abf.el7 will be installed
--> Processing Dependency: python-ioprocess >= 0.5-1 for package: vdsm-python-4.16.1-0.gita4d9abf.el7.x86_64
--> Finished Dependency Resolution
Error: Package: vdsm-4.16.1-0.gita4d9abf.el7.x86_64 (ovirt-3.5-pre)
           Requires: python-ioprocess >= 0.5-1
Error: Package: python-pthreading-0.1.3-3.el6.noarch (ovirt-3.5-epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: mom-0.4.1-2.el6.noarch (ovirt-3.5-epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-cpopen-1.3-1.el6.x86_64 (ovirt-3.5-epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: vdsm-python-4.16.1-0.gita4d9abf.el7.x86_64 (ovirt-3.5-pre)
           Requires: python-ioprocess >= 0.5-1
Error: Package: python-cpopen-1.3-1.el6.x86_64 (ovirt-3.5-epel)
           Requires: libpython2.6.so.1.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Netbulae 2014-07-30 12:18:36 UTC
I see python-ioprocess-0.6.1-1.el7.noarch.rpm in the Extras Packages for Enterprise Linux beta for 7 and python-ioprocess-0.5.0-1.el6.noarch.rpm in Epel.

But no python-ioprocess-0.5.0-1.el7.noarch.rpm

Comment 2 Netbulae 2014-07-30 12:28:19 UTC
Sorry, found it already. The EL7 release rpm should point to the EPEL 7 beta repo in ovirt35-dependencies. 

I disabled the epel repo in ovirt-3.5-dependencies.repo and after installing epel-release-7-0.2.noarch.rpm everything works fine.

Comment 3 Sandro Bonazzola 2014-08-01 07:24:57 UTC
Added python-ioprocess to packages from epel.
We also build it on jenkins, it's delivered in nightly snapshot for EL7[1], it should go in in 3.5.0 RC1.

 [1] http://jenkins.ovirt.org/job/ioprocess_master_create-rpms-el7-x86_64_merged/

Comment 4 Netbulae 2014-08-12 10:33:11 UTC
It has been changed to:

#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch

Error: Package: puppet-3.6.2-2.el7.noarch (ovirt-3.5-epel)
           Requires: rubygem(rgen)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


But Epel for 7 is still in beta, I changed it to "beta/7":

baseurl=http://download.fedoraproject.org/pub/epel/beta/7/$basearch
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch

And it works properly

Comment 5 Netbulae 2014-08-12 10:39:31 UTC
(In reply to Netbulae from comment #4)
> It has been changed to:
> 
> #baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
> mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-
> 7&arch=$basearch
> 
> Error: Package: puppet-3.6.2-2.el7.noarch (ovirt-3.5-epel)
>            Requires: rubygem(rgen)
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> 
> 
> But Epel for 7 is still in beta, I changed it to "beta/7":
> 
> baseurl=http://download.fedoraproject.org/pub/epel/beta/7/$basearch
> #mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-
> 7&arch=$basearch
> 
> And it works properly

Sorry the url above doesn't work, I actually used this one:

http://ftp.nluug.nl/pub/os/Linux/distr/fedora-epel/beta/7/x86_64/

Comment 6 Netbulae 2014-08-12 10:41:07 UTC
Sorry, I need some coffee first. It's just puppet conflicting

Comment 7 Netbulae 2014-08-12 10:41:54 UTC
Sorry, I need some coffee first. It's just puppet conflicting

Comment 8 Netbulae 2014-08-14 09:32:32 UTC
For the puppet conflict there was another dep problem bug filed.

for reference:
https://bugzilla.redhat.com/show_bug.cgi?id=1129236


Note You need to log in before you can comment on or make changes to this bug.