Bug 1124852 - The default /etc/sysconfig/docker file is a bunch of HTML
Summary: The default /etc/sysconfig/docker file is a bunch of HTML
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: docker-io
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 13:11 UTC by Taylor Braun-Jones
Modified: 2014-08-15 15:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 15:59:25 UTC


Attachments (Terms of Use)
The default docker sysconfig file with a bunch of HTML. (2.79 KB, text/plain)
2014-07-30 13:11 UTC, Taylor Braun-Jones
no flags Details

Description Taylor Braun-Jones 2014-07-30 13:11:39 UTC
Created attachment 922569 [details]
The default docker sysconfig file with a bunch of HTML.

Description of problem:
The default /etc/sysconfig/docker file is a bunch of HTML non-sense. Looks like a failed attempt by the package maintainer to download the latest docker.sysconfig file through the docker cgit web interface.

Version-Release number of selected component (if applicable):
docker-io-1.0.0-1.el7

How reproducible:
Always.

Steps to Reproduce:
1. sudo yum --enablerepo epel install -y docker-io
2. cat /etc/sysconfig/docker

Actual results:
<< See attachment >>

Expected results:
# Comment lines with instructions on how to modify the file.
# Maybe some default values already set.

Comment 1 Lokesh Mandvekar 2014-07-30 13:48:09 UTC
Hi Taylor, docker is available in RHEL7/CentOS7 by default, and this build should no longer be used.

Patrick: ping, looks like the epel7 build is still there. Could you check on that with rel-eng please?

Comment 2 Taylor Braun-Jones 2014-07-30 14:29:43 UTC
Hm, on my CentOS7 system running `repoquery --repoid=base docker-io` returns nothing. Indeed, I see no docker-io package in the index at:

http://mirror.centos.org/centos/7/os/x86_64/Packages/

Comment 3 Marek Goldmann 2014-07-30 14:37:07 UTC
(In reply to Taylor Braun-Jones from comment #2)
> Hm, on my CentOS7 system running `repoquery --repoid=base docker-io` returns
> nothing. Indeed, I see no docker-io package in the index at:
> 
> http://mirror.centos.org/centos/7/os/x86_64/Packages/

The package is called "docker" and is available in the extras repo: http://mirror.centos.org/centos/7/extras/x86_64/Packages/

Comment 4 Taylor Braun-Jones 2014-07-30 14:59:25 UTC
Thanks, problem resolved with the docker package from the CentOS7 extras repo.

It seems there are two actions that need to be taken to properly resolve this issue:

  - The docker-io package in the EPEL7 repo should be deleted
  - The docker package in the extras repo should have an 'Obsoletes: docker-io` in it's spec file

Comment 5 Lokesh Mandvekar 2014-07-30 15:11:51 UTC
(In reply to Taylor Braun-Jones from comment #4)
> Thanks, problem resolved with the docker package from the CentOS7 extras
> repo.
> 
> It seems there are two actions that need to be taken to properly resolve
> this issue:
> 
>   - The docker-io package in the EPEL7 repo should be deleted

Yup. Patrick is working with fedora rel-eng on that.

>   - The docker package in the extras repo should have an 'Obsoletes:
> docker-io` in it's spec file

I do see what you mean, but this probably won't go in as docker-io was an EPEL package (not vanilla RHEL), while docker officially first entered vanilla RHEL as 'docker'. Correct me if I'm wrong.

Comment 6 Lokesh Mandvekar 2014-08-15 15:59:25 UTC
docker-io build has been removed from epel7 https://dl.fedoraproject.org/pub/epel/beta/7/x86_64/ (nothing in there)

epel7 branch has the install steps for default docker package https://pkgs.fedoraproject.org/cgit/docker-io.git/tree/dead.package?h=epel7


Note You need to log in before you can comment on or make changes to this bug.