Bug 1124898 - no printout from canon pixma ip2600
Summary: no printout from canon pixma ip2600
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 15:06 UTC by joaolarraz
Modified: 2016-07-11 20:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 11:45:04 UTC


Attachments (Terms of Use)
printer-manager troubleshoot report (29.59 KB, text/plain)
2014-07-30 15:06 UTC, joaolarraz
no flags Details
error log (printing test page) (12.13 MB, text/plain)
2014-07-31 10:56 UTC, joaolarraz
no flags Details

Description joaolarraz 2014-07-30 15:06:02 UTC
Created attachment 922626 [details]
printer-manager troubleshoot report

Description of problem:
no printout from canon pixma ip2600

Version-Release number of selected component (if applicable):


How reproducible:
ordering print from any program (not program-related)

Steps to Reproduce:
1.hit print, select printer, ok
2.messages 'data sent' and 'print finished' ok, but no output nor movement from printer


Actual results:
no printout even when asking for a test-print from printer-manager

Expected results:
printout or conclusive\timely error message

Additional info:
Cups can't connect to server when trying to change ppd.
Additionally, printer-manager shows no id for said printer.

Comment 1 Jiri Popelka 2014-07-31 08:25:46 UTC
(In reply to joaolarraz from comment #0)
> Created attachment 922626 [details]
> printer-manager troubleshoot report

There's no error_log part. Please try to get it following:
https://fedoraproject.org/wiki/How_to_debug_printing_problems#Getting_debug_information_by_other_means

Comment 3 joaolarraz 2014-07-31 10:56:17 UTC
Created attachment 922875 [details]
error log (printing test page)

wget returned 404, attached file is  /var/log/cups/error_log converted to odt with gedit.

Comment 4 Jiri Popelka 2014-07-31 11:01:43 UTC
(In reply to joaolarraz from comment #3)
> /var/log/cups/error_log converted to odt with gedit.

The original error_log would be much better. You can compress it somehow, but it's not necessary. Thanks

Comment 5 Tim Waugh 2014-07-31 11:45:04 UTC
Looks like the (3rd party) pstocanonij filter is at fault:

D [31/Jul/2014:11:32:14 +0100] [Job 78] pstocanonij: /usr/bin/gs -r600 -g4958x7016 -q -dNOPROMPT -dSAFER -sDEVICE=ppmraw -sOutputFile=- -| /usr/local/bin/cifip2600 --imageres 600 --papersize a4 --media plain --paperload asf --bbox 9,14,585,834
[...]
D [31/Jul/2014:11:32:14 +0100] [Job 78] /usr/local/bin/cifip2600: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file or directory
[...]
D [31/Jul/2014:11:32:16 +0100] [Job 78] PID 2459 (/usr/lib/cups/filter/pstocanonij) exited with no errors.

It ought to catch this error and set its exit status appropriately.

Most likely you're using a 32-bit driver on a 64-bit system, but don't have the 32-bit dependencies installed that it requires, such as libtiff.i686.

Not a Fedora bug.


Note You need to log in before you can comment on or make changes to this bug.