Bug 1124915 - gnome-screensaver process runs twice in users sessions
Summary: gnome-screensaver process runs twice in users sessions
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-screensaver
Version: 6.5
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1172231 1269194
TreeView+ depends on / blocked
 
Reported: 2014-07-30 15:38 UTC by Tahir
Modified: 2019-03-22 07:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-03 15:34:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 642462 None None None Never

Description Tahir 2014-07-30 15:38:39 UTC
Description of problem:
On occasion on some of our systems we have two gnome-screensaver processes running. This means our users are having to log-in twice which annoys and confuses them often in equal measure. 

How reproducible:

Very difficult to definitively reproduce, just happens on occasion on machines at random times. Sorry I can't help more here. 


Steps to Reproduce:
Unknown, hard to reproduce at will. 


Actual results:

Once both gnome-screensavers are running this is the output of ps,
[root@coe ~]# ps -ef | grep -i gnome-screensaver
bwalker   1055     1  0 Jul28 ?        00:00:04 /usr/bin/gnome-screensaver --no-daemon
bwalker   1073     1  0 Jul28 ?        00:00:24 gnome-screensaver


Expected results:

Just a single gnome-screensaver process running (probably without --no-daemon flag). 


Additional info:

The parent process seems to be init. It would be useful to know what is spawning the extra gnome-screensaver process - any guidelines on how to trace the process life cycle would be very useful indeed.

This bug is mentioned elsewhere in the Linux community in various forums and in various forms, one of which being the following: 

https://bugzilla.gnome.org/show_bug.cgi?id=642462

Comment 2 Ray Strode [halfline] 2014-07-30 16:53:50 UTC
my guess is this happening because a user hits ctrl-alt-L or the screensaver key on their keyboard during the log in process.  The upstream bug report you found, points out that if gnome-screensaver is started twice in quick succession two can end up running.

gnome-screensaver --no-daemon is probably from dbus-daemon.  see:

 /usr/share/dbus-1/services/org.gnome.ScreenSaver.service  

it gets automatically started if it's accessed over the message bus and it isn't already running (which will happend when you hit ctrl-alt-L, the screensaver key on your keyboard, or run gnome-screensaver-command.

Comment 3 Tahir 2014-07-31 15:41:54 UTC
Thanks for that but I can confirm that our users are not hitting ctl+alt+L or any kind of screensaver key. 

What would happen if we put that file (/usr/share/dbus-1/services/org.gnome.ScreenSaver.service) aside on our systems?
How can we make sure that only one gnome-screensaver process ever runs?

Comment 4 Ray Strode [halfline] 2014-07-31 15:56:30 UTC
if you moved that file aside on your system the problem would most likely go away, until the next gnome-screensaver update (when it would get placed back).

The way to make sure only one gnome-screensaver process runs is to backport the patch from the bug you found.

Comment 5 Tahir 2014-08-06 11:34:01 UTC
Thank you. I have raised this as a Red Hat Support Case (Case 01168922).

Comment 7 Tahir 2014-09-04 11:35:55 UTC
Patched version of gnome-screensaver seems to fix the double gnome-screensaver problem at least for the five machines that this has been tested on:
  
http://people.redhat.com/ashishks/01168922/


Note You need to log in before you can comment on or make changes to this bug.