Bug 1124918 - Reports do not seem to be getting received by Satellite server when running on RHEL 7
Summary: Reports do not seem to be getting received by Satellite server when running o...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Configuration Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-30 15:44 UTC by Jason Montleon
Modified: 2014-08-14 07:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 07:59:57 UTC


Attachments (Terms of Use)

Description Jason Montleon 2014-07-30 15:44:24 UTC
Description of problem:
If I run puppet agent --test; puppet agent --test on a new RHEL 7 Satellite 6 server it shows up in hosts but shows up as new no matter how many runs.

Version-Release number of selected component (if applicable):
foreman-1.6.0.34-1.el7sat.noarch
ruby193-rubygem-katello-1.5.0-76.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 6 on RHEL 7
2. Disable restrict_registered_puppetmasters to work around https://bugzilla.redhat.com/show_bug.cgi?id=1108740
3. run 'puppet agent --test; puppet agent --test'

Actual results:
Host shows up on Satellite server, but is in state New

Expected results:
Host shows up on Satellite server, but is in an OK state

Additional info:

Comment 2 RHEL Product and Program Management 2014-07-30 15:54:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Dominic Cleal 2014-07-31 13:33:03 UTC
Please attach foreman-debug and/or Foreman + puppetmaster logs.

Comment 8 Dominic Cleal 2014-08-11 17:19:05 UTC
Looks like bug #1108740, as production.log is reporting this:

No Capsule server found on ["el7-smoketest.sat6.lab.eng.bos.redhat.com,OU=PUPPET,O=FOREMAN,ST=North"] and is not in trusted_puppetmaster_hosts

Could you please check the restrict_registered_puppetmasters setting is disabled?  The foreman-debug archive suggests it's at the default value.

Comment 9 Jason Montleon 2014-08-13 20:10:28 UTC
This may have been fixed in a recent compose. Previously no matter how many puppet runs I did the host would retain the N icon and there would be no reports. Checking again today on Snap 5 it appears to be working.


Note You need to log in before you can comment on or make changes to this bug.