Bug 1124988 - Allow hammer cli to install specific packages to specific systems not defined by system group
Summary: Allow hammer cli to install specific packages to specific systems not defined...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Adam Price
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1316897
TreeView+ depends on / blocked
 
Reported: 2014-07-30 19:22 UTC by Dave Sullivan
Modified: 2019-08-12 15:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-04 21:30:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4169 None None None 2016-04-26 16:55:41 UTC

Description Dave Sullivan 2014-07-30 19:22:33 UTC
Description of problem:

Currently there is no way to install packages on multiple system using CLI . there is system group feature but not always user want to install package in all systems in system group

what i am looking for is

katello -u admin -p admin system packages --install pkg1,pkg2,pkg3 --name sys1,sys2,sys2


Upstream BZ: http://projects.theforeman.org/issues/4169


Version-Release number of selected component (if applicable):

Satellite 6 Beta


How reproducible:


see above

Comment 1 RHEL Product and Program Management 2014-07-30 19:44:00 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-31 13:25:55 UTC
Connecting redmine issue http://projects.theforeman.org/issues/4169 from this bug

Comment 5 Bryan Kearney 2016-08-10 16:02:56 UTC
Upstream bug component is Content Management

Comment 6 Bryan Kearney 2016-08-10 19:01:58 UTC
Upstream bug component is Hammer - Content

Comment 7 Bryan Kearney 2016-08-10 20:03:05 UTC
Upstream bug component is Content Management

Comment 8 Bryan Kearney 2016-08-10 22:02:53 UTC
Upstream bug component is Hammer - Content

Comment 9 Bryan Kearney 2016-10-04 21:30:34 UTC
This is exists in satellite 6.2:

hammer host package install --help
Usage:
    hammer host package install [OPTIONS]

Options:
 --async                       Do not wait for the task
 --host HOST_NAME              Name to search by
 --host-id HOST_ID              
 --packages PACKAGES           List of package names
                               Comma separated list of values.
 -h, --help                    print help


Note You need to log in before you can comment on or make changes to this bug.