Bug 112508 - installing vmware breaks with syntax error
Summary: installing vmware breaks with syntax error
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-21 21:20 UTC by Thomas Könning
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-22 21:49:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-output of vmware-config.pl (1.98 KB, text/plain)
2003-12-21 21:22 UTC, Thomas Könning
no flags Details
error messages from compiling vmnet-module (10.72 KB, text/plain)
2003-12-22 21:28 UTC, Thomas Könning
no flags Details

Description Thomas Könning 2003-12-21 21:20:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031114

Description of problem:
when starting vmware-config.pl to create the vmware-kernelmodules, the
compiling of the vmnet-module breaks with a syntax error



Version-Release number of selected component (if applicable):
both kernel 2.4.22-1.2115.nptl and 2.4.22-1.2129.nptl

How reproducible:
Always

Steps to Reproduce:
1.login as root
2.starting vmware-config.pl
3.answering the questions to compile the modules with yes
    

Actual Results:  the vmon-module compiles successful;
but the vmnet-module produces a syntax error in kernel-source-file
driver.c
(under SuSE 8.2 the compilation works)


Expected Results:  the vmware-modules should have been compiled all
successfull.

Additional info:

because of the language-settings on my system, the error-messages are
partially in german.
the german word 'Syntaxfehler' means 'syntax error'

Comment 1 Thomas Könning 2003-12-21 21:22:56 UTC
Created attachment 96660 [details]
screen-output of vmware-config.pl

Comment 2 Arjan van de Ven 2003-12-21 21:38:38 UTC
this is a vmware problem; you have better chance of getting things
fixed by asking on their newsgroups...

Comment 3 Thomas Könning 2003-12-22 21:06:40 UTC
Why is this a vmware-problem?
On SuSE linux 8.2 this works!
Doesn't this point on on error in the fedora kernel sources???

best regards
Thomas Könning

Comment 4 Arjan van de Ven 2003-12-22 21:23:08 UTC
Not per se; it might just mean that vmware code needs changing to
match the kernel, or that you set something up wrongly.

Comment 5 Thomas Könning 2003-12-22 21:28:08 UTC
Created attachment 96673 [details]
error messages from compiling vmnet-module

Comment 6 Arjan van de Ven 2003-12-22 21:34:27 UTC
driver.c:1433: Warnung: implicit declaration of function `for_each_task'

That means the driver needs adapting to the newer kernel.

Comment 7 Thomas Könning 2003-12-22 21:40:24 UTC
I do not understand, this output is from a working kernel
2.4.21-1.2129.nptl. This should be the newest kernel for fedora, or not?

Question:
what about the syntax error messaged at the end of the error messages?

best regards

Comment 8 Arjan van de Ven 2003-12-22 21:49:14 UTC
The *VMWARE* driver needs updating. Period.
That's why you have to go to the vmware groups; they most likely
already have such a driver for download.

This is NOT OUR BUG. Please stop reopening it.


Note You need to log in before you can comment on or make changes to this bug.