Bug 1125083 - Ceilometer is not showing the Metrics on Compute onde
Summary: Ceilometer is not showing the Metrics on Compute onde
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 4.0
Assignee: Matthias Runge
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 03:51 UTC by Udayendu Sekhar Kar
Modified: 2018-12-09 18:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 00:56:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1278796 None None None Never

Description Udayendu Sekhar Kar 2014-07-31 03:51:48 UTC
Description of problem:
Ceilometer in Havana is not connecting with Rabbit and not showing the compute matrics on compute node.

Version-Release number of selected component (if applicable):
RHOS 4.0

How reproducible:
100% in customer's environment

Steps to Reproduce:
1. Install RHOS4
2. Configure the Ceilometer
3. Then try to check the different matrics, it will not give any info.

Actual results:
Ceilometer is not showing the Metrics on Compute onde

Expected results:
It should show the metrix on the compute node.

Additional info:

This bugzilla is opened in the upstream as well: https://bugs.launchpad.net/horizon/+bug/1278796

Comment 2 Dave Maley 2014-07-31 13:13:40 UTC
fixing flags and moving to horizon as upstream fix is in the dashboard bits

Comment 3 Matthias Runge 2014-07-31 19:17:05 UTC
The linked upstream bug report is about implementing the metering panel. That's more a new feature rather than a fixing a bug, and it was not considered as safe backport.

Your description was: Ceilometer in Havana is not connecting with Rabbit and not showing the compute matrics on compute node.

Is that accurate?

Comment 4 Udayendu Sekhar Kar 2014-08-01 03:28:41 UTC
Yes,

The description part is accurate. I just mentioned that BZ as customer has requested me to verify that I was not fully sure about it. So I asked for your confirmation.

But the main concern is ceilometer in Havana is not connecting with Rabbit and not showing the compute matrics on compute node.


Thanks,
Uday

Comment 7 Dave Maley 2014-08-01 04:26:37 UTC
Matthias - Based on the following comment from the customer in the support case I believe the description about not connecting to rabbit isn't accurate: 

"After looking at the ceilometer data carefully, I saw that that data seemed like it was getting loaded into the ceilometer database. It appears that the problem is with the horizon dashboard; specifically, with a custom availability zone, the dashboard does not show the compute metrics. There's an openstack bug for this; https://bugs.launchpad.net/horizon/+bug/1278796. Can you look at that bug and advise?"

So the problem seems to be related to the use of a custom availability zone, which does appear to match the upstream bug.

Comment 8 Matthias Runge 2014-08-04 16:49:23 UTC
Dave,

based on the bug description on launchpad, I'd advise to upgrade to Icehouse version.
A more general monitoring dashboard was developed as a new feature for Icehouse, so a fix for this wouldn't be so easy. It might be possible to use a Icehouse Dashboard on top of a Havana infrastructure. At least, it's easily possible to try it.

Comment 9 Dave Maley 2014-08-13 00:56:42 UTC
Thanks for the guidance Matthias.  We've informed the customer that this is not suitable for backport to rhel osp4 and have suggested they move to osp5 to get this functionality.


Note You need to log in before you can comment on or make changes to this bug.