Bug 1125105 - erlang packages use libsystemd-daemon.so instead of the new libsystemd.so
Summary: erlang packages use libsystemd-daemon.so instead of the new libsystemd.so
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: erlang
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 04:16 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2014-08-27 19:00 UTC (History)
4 users (show)

Fixed In Version: erlang-17.2.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-27 19:00:08 UTC


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2014-07-31 04:16:14 UTC
Description of problem:
Various erlang packages use '-lsystemd-daemon' but should switch to '-lsystemd'.
This causes it to require systemd-compat-libs, containing systemd libraries with historical names.

For longer explanation see http://www.spinics.net/lists/fedora-devel/msg200853.html.

Version-Release number of selected component (if applicable):
erlang-asn1-R16B-03.7.fc21.x86_64
erlang-dialyzer-R16B-03.7.fc21.x86_64
erlang-erts-R16B-03.7.fc21.x86_64
erlang-runtime_tools-R16B-03.7.fc21.x86_64
erlang-tools-R16B-03.7.fc21.x86_64
erlang-typer-R16B-03.7.fc21.x86_64


Note You need to log in before you can comment on or make changes to this bug.