Bug 1125197 - Endless loop in Image.getChain if a volume chain has a cycle
Summary: Endless loop in Image.getChain if a volume chain has a cycle
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.5.0
Assignee: Nir Soffer
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 09:52 UTC by Nir Soffer
Modified: 2016-02-10 19:43 UTC (History)
11 users (show)

Fixed In Version: v4.16.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:31:39 UTC
oVirt Team: Storage


Attachments (Terms of Use)
vdsm log showing the endless loop (486.06 KB, application/x-xz)
2014-07-31 09:52 UTC, Nir Soffer
no flags Details
Verification info (5.47 KB, text/plain)
2014-08-01 12:29 UTC, Nir Soffer
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30867 master MERGED image: Detect cycles in image volume chain Never
oVirt gerrit 30944 ovirt-3.5 MERGED image: Detect cycles in image volume chain Never

Description Nir Soffer 2014-07-31 09:52:27 UTC
Created attachment 922866 [details]
vdsm log showing the endless loop

Description of problem:

If an image volume chain has a cycle, Image.getChain will loop forever, trying to sort the chain, until all memory is used.

Version-Release number of selected component (if applicable):
master as of 2014-07-31

How reproducible:
Always

Steps to Reproduce:
1. Create a cycle in volume parent uuids, for example, change volume parent to itself

Actual results:
getChain looping endlessly

Expected results:
getChain raise an exception since the volume chain is illegal.

Comment 1 Nir Soffer 2014-07-31 09:53:40 UTC
Respin from bug 1124498.

Comment 2 Nir Soffer 2014-08-01 12:29:04 UTC
Created attachment 923285 [details]
Verification info

This should help qe to verify this bug.

Comment 3 Dan Kenigsberg 2014-08-01 14:11:04 UTC
Nir, do you have any guess how we got ourselves a cycle like that?

Comment 4 Nir Soffer 2014-08-01 15:37:15 UTC
See bug 1124498

Comment 5 Raz Tamir 2014-09-03 14:18:40 UTC
Verified on vdsm-4.16.2-1.gite8cba75.el6.x86_64

followed the steps to reproduce

Comment 6 Sandro Bonazzola 2014-10-17 12:31:39 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.