Bug 1125210 - rhq.autoinstall.server.admin.password is ignored
Summary: rhq.autoinstall.server.admin.password is ignored
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Installer
Version: 4.13
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 10:31 UTC by Filip Brychta
Modified: 2014-08-01 16:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 16:00:38 UTC


Attachments (Terms of Use)

Description Filip Brychta 2014-07-31 10:31:42 UTC
Description of problem:
rhq.autoinstall.server.admin.password property is ignored and rhqadmin is still used as a password.

Version-Release number of selected component (if applicable):
Version :	
4.13.0-SNAPSHOT
Build Number :	
c83e8c4

How reproducible:
Always

Steps to Reproduce:
1. unzip rhq-server-4.13.0-SNAPSHOT.zip
2. rhq-server-4.13.0-SNAPSHOT/bin/rhqctl install
3. fill all necessary properties (use different password than 'rhqadmin' for rhq.autoinstall.server.admin.password)

Actual results:
you are still able to log in under rhqadmin/rhqadmin
Filled password is not working
rhq.autoinstall.server.admin.password in rhq-server.properties is set to correct enrypted version (not rhqadmin)

Comment 1 Jay Shaughnessy 2014-08-01 15:25:35 UTC
Are you sure your DB was clean?

Comment 2 Filip Brychta 2014-08-01 16:00:38 UTC
Sorry Jay. You are right, it works.


Note You need to log in before you can comment on or make changes to this bug.