Bug 1125213 - “404 not found” error appears when access web page of MEDIUM and LARGE gear size app after new creation on STAGE
Summary: “404 not found” error appears when access web page of MEDIUM and LARGE gear s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Pod
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 10:41 UTC by Liang Xia
Modified: 2015-05-15 00:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-18 16:50:34 UTC


Attachments (Terms of Use)

Description Liang Xia 2014-07-31 10:41:00 UTC
Description of problem:
Create app on ex-std-node3 will show:
Unable to complete the requested operation due to: An invalid exit code (1) was returned from the server ex-std-node3.stg.rhcloud.com.  This indicates an unexpected problem during the execution of your request.
Reference ID: fbaa482916a253a5ead3edbadc61222e

Create app with large gear will show:
Unable to complete the requested operation due to: No district nodes available. Please try again and contact support if the issue persists. 
Reference ID: c7d11f058224d2a1cf004d2dd4c68f7a

Version-Release number of selected component (if applicable):
STG(devenv-stage_910)

How reproducible:
always

Steps to Reproduce:
1.Create apps on ex-std-node3.
2.Create apps with large gear size.
3.

Actual results:
As in description.

Expected results:
Apps created successfully.

Additional info:

Comment 3 Yan Du 2014-08-01 03:05:10 UTC
Test on STG(devenv-stage-939)

Fail to create medium app

# rhc app create diy diy-0.1 -g medium 
Application Options
-------------------
Domain:     q
Cartridges: diy-0.1
Gear Size:  medium
Scaling:    no
Creating application 'diy' ... 
Unable to complete the requested operation due to: No district nodes available.
Please try again and contact support if the issue persists.

Comment 4 Yan Du 2014-08-01 03:14:25 UTC
large gear size app could be created successfully, but got "404 not found" when access the app in website. 

# rhc appcreate p1 php-5.4 -g large --no-git
Application Options
-------------------
Domain:     q
Cartridges: php-5.4
Gear Size:  large
Scaling:    no

Creating application 'p1' ... done
Waiting for your DNS name to be available ... done

Your application 'p1' is now available.

  URL:        http://p1-q.stg.rhcloud.com/
  SSH to:     53db05462587c8f2bb0002ab@p1-q.stg.rhcloud.com
  Git remote: ssh://53db05462587c8f2bb0002ab@p1-q.stg.rhcloud.com/~/git/p1.git/

Run 'rhc show-app p1' for more details about your app.

Comment 5 Jhon Honce 2014-08-01 21:53:19 UTC
The node had been restored with the wrong ownership for the apache db files in /var/lib/openshift/.httpd.d


Note You need to log in before you can comment on or make changes to this bug.