Bug 1125226 - [Usability] The seletcted product in Step 1 page does not show up when edit rule
Summary: [Usability] The seletcted product in Step 1 page does not show up when edit rule
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Bugzilla
Classification: Community
Component: Internal Tools
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 4.4
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 11:08 UTC by Shirley Zhou
Modified: 2018-12-09 06:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 01:56:33 UTC


Attachments (Terms of Use)

Description Shirley Zhou 2014-07-31 11:08:55 UTC
Description of problem:
When I edit the one exiting rule, in step 1 page, the seleted and highlighted product did not show up. It also exist when I change to step 1 page in step 4 page.

Version-Release number of selected component (if applicable):
4.4.5023

How reproducible:


Steps to Reproduce:
1. Edit one existing rule which is created on Communicty -> Bugzilla
2. In step 1 page, check the Product box
3.

Actual results:
The highlighted Bugzilla did not show up

Expected results:
It should show up, so need drag to find it. 

Additional info:

Comment 1 Jason McDonald 2014-08-01 02:18:58 UTC
I think what you mean is that the product is selected in the listbox, but the listbox isn't at the correct scrollbar position for the selected item to be visible without dragging the scrollbar.

Comment 2 Shirley Zhou 2014-08-01 02:23:55 UTC
(In reply to Jason McDonald from comment #1)
> I think what you mean is that the product is selected in the listbox, but
> the listbox isn't at the correct scrollbar position for the selected item to
> be visible without dragging the scrollbar.


Exactly. Thanks.

Comment 3 Simon Green 2014-08-04 23:08:52 UTC
I'm not sure if this can be fixed. The same thing can be seen on search page, for example.

https://bugzilla.redhat.com/query.cgi?format=advanced&classification=Community&product=Bugzilla

The issue is that we hide (not remove) some elements from the drop down list which makes the positioning for the drop down incorrect once items have been hidden.

If someone knows how to fix it, feel free to take this bug. A quick Internet search didn't reveal the answer.

Comment 4 Matt Tyson 🤬 2014-08-05 01:08:48 UTC
I'll take a crack at it.

Comment 5 Matt Tyson 🤬 2014-08-05 01:56:33 UTC
From what I can see there's no way to shift the focus of items within a multi select box.

Unfortunately this means the bug can't be fixed.


Note You need to log in before you can comment on or make changes to this bug.