Bug 1125265 - Unable to launch instance in multi-host nova-compute
Summary: Unable to launch instance in multi-host nova-compute
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Martin Magr
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 13:13 UTC by Martin Magr
Modified: 2014-09-08 05:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 14:29:17 UTC


Attachments (Terms of Use)

Description Martin Magr 2014-07-31 13:13:26 UTC
Description of problem:
Launching instance fails with following error in nova-compute.log when more than one compute hosts have been installed:

2014-07-31 14:12:16.267 13465 ERROR nova.compute.manager [req-3d758876-c758-4113-8b11-43e5c0a4f0da 61d5d558035844459122136cf819bcb3 157fd90cef9d449cb8b30b211ee5b8aa] [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b] Instance failed to spawn
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b] Traceback (most recent call last):
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b]   File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 1714, in _spawn
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b]     block_device_info)
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b]   File "/usr/lib/python2.7/site-packages/nova/virt/libvirt/driver.py", line 2289, in spawn
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b]     block_device_info)
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b]   File "/usr/lib/python2.7/site-packages/nova/virt/libvirt/driver.py", line 3701, in _create_domain_and_network
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b]     raise exception.VirtualInterfaceCreateException()
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b] VirtualInterfaceCreateException: Virtual Interface creation failed
2014-07-31 14:12:16.267 13465 TRACE nova.compute.manager [instance: 6d4e25c8-879d-4800-ac80-f7bc8d84a96b] 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
0. Generate answer file
1. Put multiple hosts to CONFIG_COMPUTE_HOSTS  
2. Run installation with the answer file
3. Launch instance

Actual results:
VirtualInterfaceCreateException: Virtual Interface creation failed

Expected results:
Running instance

Additional info:
All-in-one installation works OK.

Comment 2 Lukas Bezdicka 2014-07-31 14:05:42 UTC
can't reproduce :(

Comment 3 Martin Magr 2014-08-01 14:29:17 UTC
Note to myself: Use valid hostnames


Note You need to log in before you can comment on or make changes to this bug.