Bug 1125302 - probe structure corruption
Summary: probe structure corruption
Keywords:
Status: CLOSED DUPLICATE of bug 1125365
Alias: None
Product: Fedora
Classification: Fedora
Component: sigrok-cli
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alex G.
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 14:08 UTC by Przemek Klosowski
Modified: 2014-07-31 16:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 16:14:57 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2014-07-31 14:08:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Przemek Klosowski 2014-07-31 14:12:35 UTC
Description of problem: the structure describing probes is corrupted and raises a free() exception


Version-Release number of selected component (if applicable):
sigrok-cli-0.4.0-2.fc20.x86_64


How reproducible: every time 


Steps to Reproduce:
1. /usr/bin/sigrok-cli --show --protocol-decoders lm75

Actual results:
*** Error in `/usr/bin/sigrok-cli': free(): invalid pointer: 0x00000000006fd110 ***
======= Backtrace: =========
/lib64/libc.so.6[0x3055c75cff]
/lib64/libc.so.6[0x3055c7cff8]
/lib64/libglib-2.0.so.0(g_free+0xf)[0x305884ef7f]
/lib64/libsigrokdecode.so.1(+0x424e)[0x7ffff7b5324e]
/lib64/libsigrokdecode.so.1(srd_decoder_unload+0x7d)[0x7ffff7b53e4d]
/lib64/libsigrokdecode.so.1(srd_decoder_unload_all+0x18)[0x7ffff7b53f68]
/lib64/libsigrokdecode.so.1(srd_exit+0x17)[0x7ffff7b51f97]
/usr/bin/sigrok-cli[0x4045a6]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x3055c21d65]
/usr/bin/sigrok-cli[0x4056fd]

Expected results: no backtrace


Additional info:

Comment 2 Dan Horák 2014-07-31 16:14:57 UTC
switching to my reproducer with full info from ABRT

*** This bug has been marked as a duplicate of bug 1125365 ***


Note You need to log in before you can comment on or make changes to this bug.