Bug 1125344 - VM dialog: changing 'Optimized For' or 'Operating System' resets various VM parameter values
Summary: VM dialog: changing 'Optimized For' or 'Operating System' resets various VM p...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Tomas Jelinek
QA Contact: Lukas Svaty
URL:
Whiteboard: virt
: 1056977 1133576 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 15:45 UTC by Pavel Novotny
Modified: 2016-02-10 19:48 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:31:54 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31892 master MERGED webadmin: changeing vm_type and os_type did reset the dialog Never
oVirt gerrit 32514 ovirt-engine-3.5 MERGED webadmin: changeing vm_type and os_type did reset the dialog Never

Description Pavel Novotny 2014-07-31 15:45:10 UTC
Description of problem:
In New/Edit VM dialog, if some vNICs are added/removed first and then 'Optimized For' drop-down is changed from Desktop to Server (and vice versa), then the vNIC info is reset back to the previous state.
Desktop/server VM type has nothing to do with vNIC settings, therefore the UI should not touch this area.

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch (beta2)

How reproducible:
100%

Steps to Reproduce:
1. Open New VM dialog.
   Current state: No vNICs are assigned by defualt. 'Optimized For' has value 'Server' by default.
2. Assign 2 vNICs to the ovirt network.
3. Change 'Optimized For' to 'Desktop'.

Actual results:
The change of value triggers a dialog refresh and after it all vNIC are gone.

Expected results:
There are still 2 vNICs assigned, as before the change of 'Optimized For' field.

Additional info:

Comment 1 Lior Vernia 2014-08-03 10:09:43 UTC
Looks like an issue with general flow in the dialog, I think due to changes related to instance type feature but difficult for me to track.

Comment 2 Pavel Novotny 2014-08-06 14:00:13 UTC
(In reply to Lior Vernia from comment #1)
> Looks like an issue with general flow in the dialog, I think due to changes
> related to instance type feature but difficult for me to track.

I agree this is a bit more general issue, I found out that also other values in the dialog (like Memory Size, CPUs, etc.) are reset when changing not only the 'Optimized For', but also 'Operating System'.

I went through the VM dialog and following VM parameter values are reset:

/General/
vNICs

/Cosnole/
Protocol
USB Support
Monitors
Single PCI
Smartcard Enabled
Soundcard enabled
VirtIO Console Device Enabled

/Host/
Migration Options select
Use custom migration

/HA/
Highly Available
Priority for Run/Migration queue radios
Watchdog Model
Watchdog Action

/Resource Allocation/
Physical Memory Guaranteed
Memory Balloon Device Enabled
VirtIO-SCSI Enabled

/Boot Options/
First Device
Second Device

Comment 3 Jiri Moskovcak 2014-08-26 14:54:48 UTC
*** Bug 1133576 has been marked as a duplicate of this bug. ***

Comment 4 Jiri Moskovcak 2014-09-04 07:49:17 UTC
*** Bug 1056977 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Svaty 2014-09-16 13:26:07 UTC
verified in vt3

Comment 6 Sandro Bonazzola 2014-10-17 12:31:54 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.