Bug 1125367 - engine-setup fails immediately unless rhevm-reports-setup and rhevm-dwh-setup are upgraded first
Summary: engine-setup fails immediately unless rhevm-reports-setup and rhevm-dwh-setup...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.4.1-1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: Petr Matyáš
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-31 16:18 UTC by wdaniel
Modified: 2019-04-28 10:49 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-30 09:41:45 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description wdaniel 2014-07-31 16:18:11 UTC
Description of problem:

When upgrading from 3.4.0 to 3.4.1, the 'engine-setup' script fails before upgrading anything unless the updated versions of rhevm-reports-seteup and rhevm-dwh-setup are downloaded prior:

[root@rhevm ~]# engine-setup
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-dwh.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-packaging-rhevm-reports.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140731150800-rcayvl.log
          Version: otopi-1.2.2 (otopi-1.2.2-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          Welcome to the RHEV 3.4 upgrade.
          Please read the RHEV 3.4 install guide
          https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html/Installation_Guide/index.html
          and the RHEV 3.4 Upgrade Guide: Tips, Considerations and Roll-back Issues article
          https://access.redhat.com/site/articles/882773
          before proceeding with the upgrade.
          Would you like to continue with the upgrade? (Yes, No) [Yes]: 
         
          --== PRODUCT OPTIONS ==--
         
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
          Setup has found updates for some packages, do you wish to update them now? (Yes, No) [Yes]: 
[ INFO  ] Checking for an update for Setup...
          An update for the Setup packages rhevm-reports-setup rhevm-dwh-setup was found. Please update that package by running:
          "yum update rhevm-reports-setup rhevm-dwh-setup"
          and then execute Setup again.
[ ERROR ] Failed to execute stage 'Environment customization': Please update the Setup packages
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140731150800-rcayvl.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140731150907-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Version-Release number of selected component (if applicable):

engine-setup 3.4.1

Steps to Reproduce:
1. On a 3.4.0 RHEV-M with reports and dwh installed, run 'yum upgrade rhevm-setup'
2. Run 'engine-setup'
3. 

Actual results:

'engine-upgrade' fails to continue early in the process unless newer reports and dwh setup packages are installed. 

Expected results:

As per all previous documentation, the engine-setup script should complete successfully and then prompt the user to upgrade other packages on completion.

Additional info:

The end of the engine-setup script still prompts the user to upgrade the other setup packages, even though the step was already performed in order to complete engine-setup:


[ INFO  ] Stage: Closing up
         
          --== SUMMARY ==--
         
[ INFO  ] DWH and/or Reports were found on this system.
          To upgrade them, please run the following commands:
          # yum update rhevm-dwh rhevm-reports
          # engine-setup

Our docs don't currently reflect this, do we need a doc bug as well?

Comment 1 Sandro Bonazzola 2014-08-05 12:20:29 UTC
maybe a documentation bug?

Comment 2 Sandro Bonazzola 2014-08-05 12:22:27 UTC
Maybe also a missing conflict on older 3.4.0 setup plugins for dwh / reports, looks like they were not upgraded

Comment 3 Yedidyah Bar David 2014-08-05 12:39:10 UTC
(In reply to wdaniel from comment #0)
> Additional info:
> 
> The end of the engine-setup script still prompts the user to upgrade the
> other setup packages, even though the step was already performed in order to
> complete engine-setup:

Not sure what exactly you refer to in "though the step was already performed in order to complete engine-setup".

> 
> 
> [ INFO  ] Stage: Closing up
>          
>           --== SUMMARY ==--
>          
> [ INFO  ] DWH and/or Reports were found on this system.
>           To upgrade them, please run the following commands:
>           # yum update rhevm-dwh rhevm-reports

Do you mean that you updated these packages as well? And still got this error?

>           # engine-setup
> 
> Our docs don't currently reflect this, do we need a doc bug as well?

From my POV there is no bug :-)
If the docs indeed say to upgrade only rhevm-setup (which I guess they do), and engine-setup checks and sees that there is also an update for other packages that are required for it to run well, and it instructs the user to update these as well, is that a problem?

Anyway, we might want to update the documentation.

We can also prevent this error by adding to rhevm-setup 3.4.1:
Conflicts: rhevm-dwh-setup < 3.4.1
Conflicts: rhevm-reports-setup < 3.4.1
I didn't check if this will be enough for yum to update them as well. We definitely do not want to Require them.

Comment 4 Yedidyah Bar David 2014-08-25 07:30:49 UTC
I didn't check the current documentation.

For 3.4, the setup code of dwh and reports was rewritten. They are now not separate utilities, but are plugins for the same engine-setup tool used to setup/upgrade the engine.

3.3->3.4 upgrade:
=================
In principle, in the upgrade path 3.3->3.4, we allow two options. In both, I assume that engine/dwh/reports 3.3 are installed and setup.

Option 1 - Engine first, dwh/reports later:
1. yum update rhevm-setup
2. engine-setup
3. yum install rhevm-dwh-setup rhevm-reports-setup
4. engine-setup
Steps 3 and 4 also "update" the engine, if there are updates, and always do some steps that every run of engine-setup does.

Option 2 - All at once:
1. yum update rhevm-setup
2. yum install rhevm-dwh-setup rhevm-reports-setup
(These two can actually be run at once by:
yum install rhevm-setup rhevm-dwh-setup rhevm-reports-setup)
3. engine-setup

3.4.z updates:
==============
Assuming engine/dwh/reports 3.4.z were already setup (either new or upgraded from earlier), a next run of 'engine-setup' will check for updates for any of the already-installed setup components (engine, dwh and reports) and will refuse to run if any are found, emitting the above message. So if all are setup, all setup packages must be updated by yum prior to running engine-setup.

I read the correspondence on the support case leading to opening this bug, and it seemed as if some information is missing. I hope now all is clear. Also other issues (such as the text suggesting to update dwh/reports also if already done) were already fixed in other bugs, and 3.4.2 should be fine in this regard.

What else is needed?

Comment 5 Sandro Bonazzola 2014-09-30 08:15:37 UTC
Not sure about the procedure for requesting documentation update. Doron?

Comment 6 Yedidyah Bar David 2014-09-30 09:41:45 UTC
Yaniv now told me that it was already updated in the docs, as can be seen in [1]. Thanks, Yaniv!

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html/Installation_Guide/Upgrading_to_Red_Hat_Enterprise_Virtualization_Manager_3.4.html

Comment 7 Yaniv Lavi 2014-09-30 09:49:46 UTC
You must update reports and dwh with engine for now on, documentation was changed to reflect that. Please yum update all setup packages or it will fail by design.


Note You need to log in before you can comment on or make changes to this bug.