Bug 112563 - Fix default sample config, explicitly disable test suite
Fix default sample config, explicitly disable test suite
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-22 16:52 EST by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-18 18:44:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to 1.99_12, rename perl.conf to 00-perl.conf etc (2.56 KB, patch)
2004-01-24 09:49 EST, Ville Skyttä
no flags Details | Diff
Fix sample config, explicitly disable test suite (2.83 KB, patch)
2005-04-18 12:36 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2003-12-22 16:52:35 EST
httpd.conf has "conf.d/*.conf" which neatly includes all
module-specific snippets.  However, the order of the inclusion
matters, and those files will be included in alphabetical order.

For example, if one has /etc/httpd/conf.d/foo.conf and tries to use
<IfModule mod_perl.c> there, mod_perl has not been loaded and
<IfModule> will return false.  On the other hand, if one has
/etc/httpd/conf.d/zzz.conf, mod_perl has been loaded before that
because perl.conf < zzz.conf.

I'd suggest renaming perl.conf to something that is guaranteed to sort
alphabetically early, such as 00-perl.conf so add-on packages and
local config snippets can just drop in their files to conf.d and rely
on that all the modules have been loaded.

mod_perl is not alone in this, all "system installed" config snippets
should probably do the same, at least those which load any modules
(SSL, PHP, possibly also welcome.conf etc etc).
Comment 1 Ville Skyttä 2004-01-24 09:49:01 EST
I will attach a patch which does this, and upgrades to 1.99_12.
Comment 2 Ville Skyttä 2004-01-24 09:49:44 EST
Created attachment 97236 [details]
Update to 1.99_12, rename perl.conf to 00-perl.conf etc

The patch is in UTF-8.
Comment 3 Ville Skyttä 2004-01-24 18:56:25 EST
Oh, and Apache::Status no longer needs Apache::compat, that can be
removed from the config file.
Comment 4 Ville Skyttä 2005-04-18 12:34:42 EDT
Most of this is redundant now, I'm attaching a patch containing the still
relevant bits.  (httpd/conf.d snippet renaming dropped as it hasn't happened
with other Apache modules either.)

PerlWarn and PerlTaintCheck are deprecated in favour of PerlSwitches.
http://perl.apache.org/docs/2.0/user/porting/compat.html

Apache::Status has been renamed to Apache2::Status, and it no longer needs
Apache::compat (which has also been renamed to Apache2::compat).

As of 2.0.0-0.rc5.2, the non-running of the test suite is currently guarded by a
bug: "%ifarch 1386".  This patch makes the intention clearer although the test
suite isn't really ready to be run even after this fix.
Comment 5 Ville Skyttä 2005-04-18 12:36:01 EDT
Created attachment 113330 [details]
Fix sample config, explicitly disable test suite

Note You need to log in before you can comment on or make changes to this bug.