Bug 1125765 - Nothing happens when "install to hard drive" is run.
Summary: Nothing happens when "install to hard drive" is run.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer LiveCD
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: z1
: Installer
Assignee: Dan Radez
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1125770 1127012 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 03:07 UTC by August Simonelli
Modified: 2014-10-01 13:25 UTC (History)
10 users (show)

Fixed In Version: rhelosp-installer-live-20140912.1.iso
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 13:25:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description August Simonelli 2014-08-01 03:07:57 UTC
Description of problem:
After going through the full rhel-osp-installer install that is started on LiveCD bootup I click "Install to Hard Drive" and nothing happens. 

Version-Release number of selected component (if applicable):
rhelosp-installer-live-2014-07-21.1.poodle.iso

How reproducible:
Run installer, without without networking (ie manual networking as well).

Steps to Reproduce:
1. Boot LiveCD
2. Run through installer in terminal window.
3. Complete installer.
4. Double click "Install to Hard Drive"

Actual results:
Nothing happens.

Expected results:
Configured image is written to disk and livecd install reboots. I expect to see a working foreman install with all the settings i just entered.

Additional info:
I tried running liveinst from the console (as root) and it didn't work. I did an xhost+ and that allowed anaconda to start. Running anaconda the following happened:

The installer starts up. I hit the first "next" and instantly get the error dialog:

"An error occurred when attempting to load an installer interface component. 
className = Keyboard Window"

I can choose "exit" or "retry." Retry brings the dialog back. Exit brings me to a "The system will now reboot" dialog with a big "Reboot" button. Clicking it does nothing but exit the installer.

Comment 3 August Simonelli 2014-08-01 07:01:14 UTC
Some additional notes, seems as if liveinst require NetworkManager to be running. For anything to work i need to run xhost+ and /etc/init.d/NetworkManager start first.

Could this be something about my test environment? (Fusion Pro). Is this a graphics issue maybe?

Comment 4 Mike Burns 2014-08-01 09:53:21 UTC
We really shouldn't put the install to disk option on the desktop.  It will (if working correctly) install the base image to disk, but not the just deployed foreman instance.  

A longer term goal would be to make it write the current state to disk.

Comment 5 Mike Burns 2014-08-01 09:55:24 UTC
*** Bug 1125770 has been marked as a duplicate of this bug. ***

Comment 7 Mike Burns 2014-08-06 13:53:04 UTC
*** Bug 1127012 has been marked as a duplicate of this bug. ***

Comment 8 Dan Radez 2014-08-11 17:23:39 UTC
I've committed a fix to remove the icon to the desktop to the rhelosp-installer-live distgit repo.

Comment 12 Alexander Chuzhoy 2014-09-15 18:05:55 UTC
Verified: rhelosp-installer-live-6.5-20140912.1.iso




Based on comment #4 and comment #8 - I understand that the "Install to Hard Drive" button shouldn't exist on the desktop and it doesn't.

Comment 14 errata-xmlrpc 2014-10-01 13:25:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.