Bug 1125822 - Failed to create app with zend-6.1 cartridge on STG
Summary: Failed to create app with zend-6.1 cartridge on STG
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Vojtech Vitek
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 07:10 UTC by Meng Bo
Modified: 2015-05-15 00:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 00:50:13 UTC


Attachments (Terms of Use)

Description Meng Bo 2014-08-01 07:10:22 UTC
Description of problem:
Try to create new app with zend cartridge will always get the following error:
Unable to complete the requested operation due to: An invalid exit code (1) was returned from the server ex-std-node1.stg.rhcloud.com.
This indicates an unexpected problem during the execution of your request.

The issue happens for all stg small nodes.
And it was working well on devenv-stage_937 yesterday.

Version-Release number of selected component (if applicable):
STG (devenv-stage_939)

How reproducible:
always

Steps to Reproduce:
1. Create zend app
# rhc app create zend61 zend-6.1 -p123
2.
3.

Actual results:
Will fail with following error:
Unable to complete the requested operation due to: An invalid exit code (1) was returned from the server ex-std-node1.stg.rhcloud.com.
This indicates an unexpected problem during the execution of your request.

Expected results:
Should be able to create zend app.

Additional info:
Found the following error in new relic,

OpenShift::Runtime::FileLockError: Failed to lock file system entry [/var/lib/openshift/53db301e2587c8a917000826/.pearrc]: No such file or directory - /var/lib/openshift/53db301e2587c8a917000826/.pearrc

Comment 1 Vojtech Vitek 2014-08-01 16:27:56 UTC
https://github.com/openshift/li/pull/2774
https://github.com/openshift/li/pull/2775

Note for QE:
If you don't have any backups of your INT/STG apps and you already proceeded with the previous migration, you might want to restore the PEARs with the following command:
> mv ${OPENSHIFT_ZEND_DIR}php-5.4/share/pear{-to-be-removed,}

Comment 2 openshift-github-bot 2014-08-01 17:34:18 UTC
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/52ccd3a01ceef45bfbe2e81ea0f6f54e12a15487
Revert "Remove extra Zend's PEAR directory"

This reverts commit add045f85bd4714e3c10a3876d231f0c89f00986.

Bug 1125822 - https://bugzilla.redhat.com/show_bug.cgi?id=1125822
Bug 1125215 - https://bugzilla.redhat.com/show_bug.cgi?id=1125215

Conflicts:
	cartridges/zend/versions/6.1/bin/upgrade

Comment 3 Meng Bo 2014-08-04 05:54:24 UTC
Checked on current STG (devenv-stage_946), issue has been fixed.

Zend app can be created and jenkins build can be performed for existing zend app.


Note You need to log in before you can comment on or make changes to this bug.