Bug 112593 - rewrite perl-XML-Dumper spec
rewrite perl-XML-Dumper spec
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-XML-Dumper (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-23 17:04 EST by Peter Bieringer
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 20:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rewritten specfile (2.58 KB, text/plain)
2005-04-26 15:22 EDT, Ville Skyttä
no flags Details

  None (edit)
Description Peter Bieringer 2003-12-23 17:04:51 EST
Description of problem:

Using this version of XML::Dumper I ran into some very strange
problems which weren't expected during storing a Perl hash into XML.

E.g. if a key contain char ', strange things are happen (value isn't
stored in XML.

Version-Release number of selected component (if applicable):
perl-XML-Dumper-0.4-25.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Create a hash where a key contain a '
    

Actual Results:  Problems

Expected Results:  No problems

Additional info:

All issues I ran into are solved using current version 0.67.
According to the ChangeLog, many issues were solved since 0.40.

I found version 0.40 very unuseful...
Comment 1 Peter van Egdom 2004-04-06 10:41:38 EDT
Both Fedora Core release 1.91 (FC2) and the Fedora Core development
tree contain the package "perl-XML-Dumper-0.71-1".

Does this package solve your issues?
Comment 2 Warren Togami 2005-04-25 20:42:57 EDT
perl-XML-Dumper could use a spec rewrite
Comment 3 Ville Skyttä 2005-04-26 15:22:07 EDT
Created attachment 113685 [details]
Rewritten specfile

0.4 had indeed some serious XML escaping bugs.	The following trivial script
demonstrates the issues with it, and works as expected with 0.71:

  #!/usr/bin/perl
  use XML::Dumper;
  my %h = ( "foo'bar" => '"quu<>x', 'b"a"r' => "baz" );
  print new XML::Dumper->pl2xml(\%h);

Attached is a specfile rewrite which fixes the build error with 0.71-3 as well
as some other smallish issues (see %changelog).
Comment 4 Warren Togami 2005-04-26 20:25:05 EDT
Thanks dude

Note You need to log in before you can comment on or make changes to this bug.