Bug 1126021 - ipa-server-install --uninstall doesn't restore runlevels correctly
Summary: ipa-server-install --uninstall doesn't restore runlevels correctly
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: pre-dev-freeze
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
: 1223659 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 15:32 UTC by David Spurek
Modified: 2016-01-29 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-29 13:21:18 UTC


Attachments (Terms of Use)

Description David Spurek 2014-08-01 15:32:30 UTC
Description of problem:
ipa-server-install --uninstall doesn't restore runlevels correctly for certmonger and kadmin

clean machine, before ipa-server-install:
[root@pes-guest-79 sanity-ipa-install]# chkconfig --list certmonger
certmonger     	0:off	1:off	2:off	3:on	4:on	5:on	6:off

[root@pes-guest-79 sanity-ipa-install]# chkconfig --list kadmin
kadmin         	0:off	1:off	2:off	3:off	4:off	5:off	6:off

after ipa-server-install
[root@pes-guest-79 sanity-ipa-install]# chkconfig --list certmonger
certmonger     	0:off	1:off	2:off	3:on	4:on	5:on	6:off

[root@pes-guest-79 sanity-ipa-install]# chkconfig --list kadmin
kadmin         	0:off	1:off	2:off	3:off	4:off	5:off	6:off

after ipa-server-install --uinstall
[root@pes-guest-79 sanity-ipa-install]# chkconfig --list certmonger
certmonger     	0:off	1:off	2:off	3:off	4:off	5:off	6:off

[root@pes-guest-79 sanity-ipa-install]# chkconfig --list kadmin
service kadmin supports chkconfig, but is not referenced in any runlevel (run 'chkconfig --add kadmin')


ipa server probably wrongly assumes that certmonger isn't enabled by default.
I don't know what it do with kadmin service, but it damages kadmin's runlevels.


Version-Release number of selected component (if applicable):
ipa-server-3.0.0-37.el6

How reproducible:


Steps to Reproduce:
1.ipa-server-install
2.ipa-server-install --uninstall
3.

Actual results:


Expected results:


Additional info:

Comment 1 Martin Kosek 2014-08-04 08:51:16 UTC
This is a valid report, this problem is also present in upstream FreeIPA. I will open an upstream ticket.

Note that given the limited severity of the bug, there is a high probability it would be fixed in RHEL-7.x product only. Please provide justification if you do not agree.

Comment 2 Martin Kosek 2014-08-04 08:55:58 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4467

Comment 3 Martin Kosek 2014-08-07 09:14:09 UTC
This ticket was triaged, moved to Future Releases milestone, meaning it is not planned for a close upstream release. Please provide proper justification (or even a patch) to let us re-prioritize.

Comment 7 Petr Vobornik 2015-06-17 14:58:21 UTC
*** Bug 1223659 has been marked as a duplicate of this bug. ***

Comment 8 Martin Kosek 2016-01-29 13:21:18 UTC
Thank you taking your time and submitting this request for Red Hat Enterprise Linux. Unfortunately, this bug was not given a priority and was deferred both in the upstream project and in Red Hat Enterprise Linux.

Given that we are unable to fulfill this request in following Red Hat Enterprise Linux releases, I am closing the Bugzilla as WONTFIX. To request that Red Hat re-considers the decision, please re-open the Bugzilla via appropriate support channels and provide additional business and/or technical details about its importance to you.

Note that you can still track this request or even contribute patches in the referred upstream Trac ticket.


Note You need to log in before you can comment on or make changes to this bug.