Bug 1126040 - Parameters which can be configured via config file or katello-installer shouldn't be user editable from settings menu
Summary: Parameters which can be configured via config file or katello-installer shoul...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 16:33 UTC by Sachin Ghai
Modified: 2014-08-11 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 16:52:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sachin Ghai 2014-08-01 16:33:27 UTC
Description of problem:
There are few parameters which are currently editable from settings submenu. For example:

- General_tab
    - foreman_url
- Auth_tab
    - oauth_consumer_key
    - oauth_secret_key
    - signo_url
    - ssl_client_dn_env
    - ssl_client_verify_env
- Provisioning_tab
    - ssl_ca_file
    - ssl_certificate
    - ssl_priv_key 

I think config files are the best place to edit the values of these. Katello-installer itself sets the value of few. So these param shouldn't be user editable.

Version-Release number of selected component (if applicable):
sat6 GA snap3

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
The above listed parameters which includes some ssl_key stuff or oauth stuff shouldn't be user editable.

Additional info:

Comment 1 Dominic Cleal 2014-08-01 16:41:14 UTC
Settings that are set in /etc/foreman/settings.yml already are read-only, e.g. the oauth_* settings mentioned are showing as read-only here.

Moving to the installer, maybe it's deliberately changing the live value so they remain mutable.

Comment 3 Sachin Ghai 2014-08-04 08:04:24 UTC
Yeah.. oauth_* settings are read-only. Thanks for confirming this.

Comment 4 Sachin Ghai 2014-08-04 08:11:44 UTC
Any reason why foreman_url and signo_url are editable ? I think these params should also be read-only. thanks.

Comment 5 Dominic Cleal 2014-08-04 08:15:23 UTC
(In reply to Sachin Ghai from comment #4)
> Any reason why foreman_url and signo_url are editable ? I think these params
> should also be read-only. thanks.

There are many reasons you may need to change it, e.g. deploying the application behind a load balancer, or unusual DNS setups.  I don't really follow why the user should *not* be able to update the URL.  signo_url is unused here.

Comment 6 Sachin Ghai 2014-08-04 08:31:11 UTC
(In reply to Dominic Cleal from comment #5)
> (In reply to Sachin Ghai from comment #4)
> > Any reason why foreman_url and signo_url are editable ? I think these params
> > should also be read-only. thanks.
> 
> There are many reasons you may need to change it, e.g. deploying the
> application behind a load balancer, or unusual DNS setups.  I don't really
> follow why the user should *not* be able to update the URL.  signo_url is
> unused here.

thank you for clarifying. I'm just asking/checking which parameters should be editable and why as I'm not 100% sure about all params. This kind of reasoning helps to understand actual use of these params too.

Comment 8 Bryan Kearney 2014-08-11 16:52:06 UTC
This is a not a bug we are planning to fix. If you disagree, please reopen.


Note You need to log in before you can comment on or make changes to this bug.