Bug 1126042 - yum update - conflicting dependencies
Summary: yum update - conflicting dependencies
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 16:41 UTC by lejeczek
Modified: 2014-09-01 13:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 13:11:57 UTC


Attachments (Terms of Use)

Description lejeczek 2014-08-01 16:41:20 UTC
Description of problem:

--> Processing Dependency: libedataserver-1.2.so.18()(64bit) for package: gnome-phone-manager-0.69-5.fc21.x86_64
--> Processing Dependency: libedataserver-1.2.so.18()(64bit) for package: gnome-shell-3.13.4-2.fc22.x86_64
--> Processing Dependency: libedataserver-1.2.so.18()(64bit) for package: 1:folks-0.9.6-5.fc21.x86_64
--> Processing Dependency: libedataserver-1.2.so.18()(64bit) for package: gnome-contacts-3.13.3-1.fc21.x86_64
---> Package libcryptui.x86_64 0:3.12.2-3.fc22 will be installed
--> Finished Dependency Resolution
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebook-1.2.so.14()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebook-1.2.so.14()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebook-1.2.so.15()(64bit)
Error: Package: gnome-phone-manager-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedataserver-1.2.so.18()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedataserver-1.2.so.18()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedataserver-1.2.so.19()(64bit)
Error: Package: gnome-shell-3.13.4-2.fc22.x86_64 (@rawhide)
           Requires: libedataserver-1.2.so.18()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedataserver-1.2.so.18()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedataserver-1.2.so.19()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebackend-1.2.so.7()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebackend-1.2.so.7()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebackend-1.2.so.9()(64bit)
Error: Package: gnome-contacts-3.13.3-1.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedata-book-1.2.so.20()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedata-book-1.2.so.20()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedata-book-1.2.so.24()(64bit)
Error: Package: gnome-phone-manager-telepathy-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebackend-1.2.so.7()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebackend-1.2.so.7()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebackend-1.2.so.9()(64bit)
Error: Package: gnome-contacts-3.13.3-1.fc21.x86_64 (@rawhide/rawhide)
           Requires: libcamel-1.2.so.49()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libcamel-1.2.so.49()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libcamel-1.2.so.50()(64bit)
Error: Package: gnome-phone-manager-telepathy-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedataserver-1.2.so.18()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedataserver-1.2.so.18()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedataserver-1.2.so.19()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libcamel-1.2.so.49()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libcamel-1.2.so.49()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libcamel-1.2.so.50()(64bit)
Error: Package: gnome-contacts-3.13.3-1.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedataserver-1.2.so.18()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedataserver-1.2.so.18()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedataserver-1.2.so.19()(64bit)
Error: Package: gnome-phone-manager-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedata-book-1.2.so.20()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedata-book-1.2.so.20()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedata-book-1.2.so.24()(64bit)
Error: Package: gnome-shell-3.13.4-2.fc22.x86_64 (@rawhide)
           Requires: libecal-1.2.so.16()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libecal-1.2.so.16()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libecal-1.2.so.17()(64bit)
Error: Package: gnome-phone-manager-telepathy-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedata-book-1.2.so.20()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedata-book-1.2.so.20()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedata-book-1.2.so.24()(64bit)
Error: Package: gnome-phone-manager-telepathy-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libcamel-1.2.so.49()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libcamel-1.2.so.49()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libcamel-1.2.so.50()(64bit)
Error: Package: gnome-contacts-3.13.3-1.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebackend-1.2.so.7()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebackend-1.2.so.7()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebackend-1.2.so.9()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedata-book-1.2.so.20()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedata-book-1.2.so.20()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedata-book-1.2.so.24()(64bit)
Error: Package: gnome-phone-manager-telepathy-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebook-1.2.so.14()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebook-1.2.so.14()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebook-1.2.so.15()(64bit)
Error: Package: gnome-phone-manager-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebackend-1.2.so.7()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebackend-1.2.so.7()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebackend-1.2.so.9()(64bit)
Error: Package: gnome-contacts-3.13.3-1.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebook-1.2.so.14()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebook-1.2.so.14()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebook-1.2.so.15()(64bit)
Error: Package: gnome-phone-manager-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libcamel-1.2.so.49()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libcamel-1.2.so.49()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libcamel-1.2.so.50()(64bit)
Error: Package: gnome-phone-manager-0.69-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libebook-1.2.so.14()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libebook-1.2.so.14()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libebook-1.2.so.15()(64bit)
Error: Package: gnome-shell-3.13.4-2.fc22.x86_64 (@rawhide)
           Requires: libcamel-1.2.so.49()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libcamel-1.2.so.49()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libcamel-1.2.so.50()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (@rawhide/rawhide)
           Requires: libedataserver-1.2.so.18()(64bit)
           Removing: evolution-data-server-3.12.4-4.fc22.x86_64 (@rawhide)
               libedataserver-1.2.so.18()(64bit)
           Updated By: evolution-data-server-3.13.4-1.fc22.x86_64 (rawhide)
              ~libedataserver-1.2.so.19()(64bit)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Milan Crha 2014-09-01 10:49:15 UTC
This might be fixed now. The problem was that evolution-data-server's update had a soname version bump, which required rebuild of dependencies including folks and gnome-phone-manager, but the folks could not be immediately rebuilt, due to other dependency errors of it (folks package). As the rebuilds are finally done, the update should work again. Please verify and eventually close this bug report. Thanks in advance.

Comment 2 lejeczek 2014-09-01 12:15:28 UTC
yes, it's fixed now, please feel free to close the report, thanks.

Comment 3 Milan Crha 2014-09-01 13:11:57 UTC
Thanks, I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.