Bug 1126084 - Rubygem-Staypuft: Nova deployment gets paused with error on installing the compute nodes. Get the following in the report: change from absent to present failed: Execution of '/usr/bin/nova-manage floating create 10.8.30.100/31' returned 1: Command failed
Summary: Rubygem-Staypuft: Nova deployment gets paused with error on installing the c...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-01 20:21 UTC by Alexander Chuzhoy
Modified: 2014-08-20 23:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 12:41:37 UTC


Attachments (Terms of Use)

Description Alexander Chuzhoy 2014-08-01 20:21:29 UTC
Rubygem-Staypuft:  Nova deployment gets paused with error on installing the compute nodes. Get the following in the report: change from absent to present failed: Execution of '/usr/bin/nova-manage floating create 10.8.30.100/31' returned 1: Command failed


Environment:
rhel-osp-installer-0.1.6-5.el6ost.noarch
openstack-puppet-modules-2014.1-19.9.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch


Steps to reproduce:
1. install rhel-osp-installer.
2. Configure/run a nova deployment with Tenant Network Type "Flat with DHCP"
  a. Floating IP range for external network: 10.8.30.100/31
  b. Private IP range for tenant networks: 192.168.32.0/24

Result:
The deployment gets paused with error upon installing the compute nodes - 60%.

Expected result:
A successful deployment.

Comment 3 Jason Guiditta 2014-08-04 13:48:58 UTC
Sasha, can you see what is in the nova-manage log and attach it?  Also, do you get the same fail if you run that command by hand?

Comment 4 Jason Guiditta 2014-08-04 14:04:07 UTC
Also, the controller's yaml would make it easier for me to attempt to reproduce

Comment 5 Jason Guiditta 2014-08-04 17:54:56 UTC
Based on the input values, I think this is exactly the same error as https://bugzilla.redhat.com/show_bug.cgi?id=1126072.  If you have nova-manage.log from the compute, that would verify, I suspect you will see the same error I did with /31.

Comment 6 Omri Hochman 2014-08-04 18:30:52 UTC
Yes - It's probably the same issue. 

We should in QE use /24 (and not /31) . 

Example: 
external network: 10.8.30.100/24  private IP range for tenant networks: 192.168.100.0/24

Comment 7 Mike Burns 2014-08-05 18:56:17 UTC
Based on comments, this is due to bad configuration and is a valid failure.  Closing as notabug.  Please reopen if you disagree

Comment 8 Alexander Chuzhoy 2014-08-05 19:48:29 UTC
I reproduced this bug using 10.8.30.100/30.

Seems like this is related to the fact that both compute nodes (have 2 compute nodes in the same deployment) tried that at the same time.

running puppet agent on the host with the error and resuming the deployment resulted in successful deployment.

Comment 9 Alexander Chuzhoy 2014-08-05 21:54:20 UTC
Ok, having a deployment with 1 compute succeedes.
So, the investigation should focus on why 2 computes fail - probably run the network create command simultaneously.

Comment 10 nlevinki 2014-08-06 10:47:03 UTC
deployed successfully with 2 compute nodes using this ip subnets
External network: 10.XX.XX.100/21  private IP range for tenant networks: 192.168.100.0/22

Comment 12 Mike Burns 2014-08-08 12:41:37 UTC
based on comment 10, closing as this works as expected


Note You need to log in before you can comment on or make changes to this bug.