Bug 1126121 - [abrt] system-config-httpd: ApacheGizmo.py:755:testServerName:TestError: The server name may only contain alphanumeric characters
Summary: [abrt] system-config-httpd: ApacheGizmo.py:755:testServerName:TestError: The ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-httpd
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mosaab Alzoubi
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0626e6882206f86ea171f6d38f2...
: 1182128 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-02 03:18 UTC by Jake Jackson
Modified: 2015-03-25 03:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-25 03:15:32 UTC


Attachments (Terms of Use)
File: backtrace (917 bytes, text/plain)
2014-08-02 03:18 UTC, Jake Jackson
no flags Details
File: environ (268 bytes, text/plain)
2014-08-02 03:18 UTC, Jake Jackson
no flags Details

Description Jake Jackson 2014-08-02 03:18:35 UTC
Version-Release number of selected component:
system-config-httpd-1.5.5-6.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /usr/share/system-config-httpd/ApacheConf.py
executable:     /usr/share/system-config-httpd/ApacheConf.py
kernel:         3.15.6-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
ApacheGizmo.py:755:testServerName:TestError: The server name may only contain alphanumeric characters

Traceback (most recent call last):
  File "/usr/share/system-config-httpd/ApacheConf.py", line 265, in on_main_ok_button_clicked
    control.dehydrate_main ()
  File "/usr/share/system-config-httpd/ApacheControl.py", line 130, in dehydrate_main
    stack.apache.ServerName = widget.get_text ()
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 701, in __setattr__
    self.test_attr (attr, value)
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 762, in test_attr
    apply (Apache.__dict__['test' + attr], (self, value))
  File "/usr/share/system-config-httpd/ApacheGizmo.py", line 755, in testServerName
    raise TestError, "The server name may only contain alphanumeric characters"
TestError: The server name may only contain alphanumeric characters

Local variables in innermost frame:

Potential duplicate: bug 768821

Comment 1 Jake Jackson 2014-08-02 03:18:37 UTC
Created attachment 923430 [details]
File: backtrace

Comment 2 Jake Jackson 2014-08-02 03:18:39 UTC
Created attachment 923431 [details]
File: environ

Comment 4 Fedora Admin XMLRPC Client 2015-03-15 01:39:59 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Mosaab Alzoubi 2015-03-25 03:15:32 UTC
"The server name may only contain alphanumeric characters"

You must use alphabetical or numeral characters only.

Comment 6 Mosaab Alzoubi 2015-03-25 03:20:12 UTC
*** Bug 1182128 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.