Bug 1126158 - Evince does not render document text in hiDPI
Summary: Evince does not render document text in hiDPI
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 20
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-02 21:14 UTC by John Heidemann
Modified: 2014-09-01 21:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 09:48:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 723431 None None None Never

Description John Heidemann 2014-08-02 21:14:43 UTC
[this text is copied from upstream https://bugzilla.gnome.org/show_bug.cgi?id=723431; they have a fix.]

Description of problem:
on high dpi screens, evince makes all text look blurry.
(A really bad outcome for someone who bought a hidpi display to get extra sharpness).


Version-Release number of selected component (if applicable):
evince-3.10.3-1.fc20.x86_64

How reproducible:
every time

Steps to Reproduce:
1.Grab a document with a ton of text, such as
http://www.revenuquebec.ca/documents/fr/publications/in/in-307%282012-06%29.pdf

2. opne it in evince in high-DPI (aka "retina") mode:
    GDK_SCALE=2 evince file.pdf

Note that this operation is the DEFAULT on computers with hidpi displays
(like the lenovo x1 carbon generation 2).

3. you will see the fonts are blurry instead of being super sharp, as they are
rendered at 1.0 scale and then stretched.

4. compare to default evince:
    GDK_SCALE=1 evince file.pdf

Actual results:
blurry text in hidpi mode


Expected results:
hidpi displays should look better, not worse!

Additional info:
Problem is fixed upstream.
See https://bugzilla.gnome.org/show_bug.cgi?id=723431

This is a request to backport that fix into fedora 20 or 21, since hidpi is here today.

Comment 1 Marek Kašík 2014-09-01 09:48:13 UTC
Hi John,

I've looked at the needed patches to fix this and I've decided to not backport them to Fedora 20. The patches change a lot of code and depend on several other changes because they are almost 2 releases far from what we have in Fedora 20.
The bug is already fixed in Fedora 21 and rawhide.

Regards

Marek

Comment 2 John Heidemann 2014-09-01 21:24:43 UTC
Your call as maintainer.

I hope F21 doesn't slip further :-)


Note You need to log in before you can comment on or make changes to this bug.