Bug 1126180 - Remove or validate index for numaNodes under vm
Summary: Remove or validate index for numaNodes under vm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-3.6.3
: ---
Assignee: Roman Mohr
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 08:16 UTC by Artyom
Modified: 2016-03-11 07:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The engine allowed the creation of numa nodes with arbitrary indices. Consequence: libvirt requires a continuous numa node index sequence for virtual numa nodes. As a result starting the VM failed in a non interactive way. Fix: Validate indices on all numa related operations (add, remove, modify nodes) Result: The user gets immediate feedback through UI or REST if the numa related command execution destroys the index sequence.
Clone Of:
Environment:
Last Closed: 2016-03-11 07:24:04 UTC
oVirt Team: SLA
rule-engine: ovirt-3.6.z+
rule-engine: exception+
rule-engine: planning_ack+
rgolan: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 46536 master MERGED core: Only allow continuous numa node indices 2016-01-27 11:42:16 UTC
oVirt gerrit 46627 master ABANDONED core: Fix check if enought cpus for numa nodes are there Never
oVirt gerrit 48720 master MERGED core: Refactor NUMA node validation Never
oVirt gerrit 49163 ovirt-engine-3.6 MERGED core: Refactor NUMA node validation Never
oVirt gerrit 52924 ovirt-engine-3.6 MERGED core: Only allow continuous numa node indices 2016-02-02 14:53:17 UTC
oVirt gerrit 53033 ovirt-engine-3.6.3 MERGED core: Only allow continuous numa node indices 2016-02-09 09:05:24 UTC

Description Artyom 2014-08-03 08:16:51 UTC
Description of problem:
numaNode index is mandatory when create vm via REST and it also possible to change index via update, but this index not affect on something and just add complexity and bugs, for example if I create two numaNodes with the same index, via REST I can see that two numa nodes appear, but vi numactl --show on guest OS I can see just one NUMA node

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create two numa nodes via REST with the same index
2.
3.

Actual results:
Nodes created and I can see two NUMA nodes via REST, but on guest OS I can see just one NUMA node

Expected results:
Or add validation and restrict to create NUMA nodes with the same indexes(also other validation like character instead of integer...), or just give to engine possibility automatically set index to NUMA node and restrict to set NUMA node for user

Additional info:

Comment 1 Sandro Bonazzola 2015-01-21 16:08:24 UTC
oVirt 3.5.1 has been released, re-targeting to 3.6.0 as not marked as urgent / high severity or priority

Comment 3 Roman Mohr 2015-09-09 08:38:04 UTC
(In reply to Artyom from comment #0)
> Description of problem:
> numaNode index is mandatory when create vm via REST and it also possible to
> change index via update, but this index not affect on something and just add
> complexity and bugs, for example if I create two numaNodes with the same
> index, via REST I can see that two numa nodes appear, but vi numactl --show
> on guest OS I can see just one NUMA node

I see two bugs here:
 1) The REST response looks like the change is immediately applied, but such changes only take effect after a restart. This will be fixed in Bug 1254910
 2) The numNode index is currently mandatory but should not be there at all
 
> Actual results:
> Nodes created and I can see two NUMA nodes via REST, but on guest OS I can
> see just one NUMA node

Comment 4 Red Hat Bugzilla Rules Engine 2015-10-19 11:01:13 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 5 Sandro Bonazzola 2015-10-26 12:50:27 UTC
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high

Comment 6 Sandro Bonazzola 2015-11-05 08:21:34 UTC
oVirt 3.6.0 has been released on November 4th, re-targeting to 4.0 since this bug has been marked with severity < high

Comment 7 Red Hat Bugzilla Rules Engine 2015-11-16 14:07:31 UTC
This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.

Comment 8 Red Hat Bugzilla Rules Engine 2015-12-02 10:20:49 UTC
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

Comment 9 Red Hat Bugzilla Rules Engine 2015-12-16 21:35:57 UTC
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.

Comment 10 Artyom 2016-02-21 14:01:25 UTC
Verified on rhevm-backend-3.6.3.2-0.1.el6.noarch

<fault>
<reason>Operation Failed</reason>
<detail>[Expected a continuous sequence of 0-1 for 2 numa nodes. Missing indices 1. Assign indices with increasing order starting from 0 to your virtual numa nodes.]</detail>
</fault>

<fault>
<reason>Operation Failed</reason>
<detail>[NUMA node with index 0 exists at least twice.]</detail>
</fault>


Note You need to log in before you can comment on or make changes to this bug.