Bug 1126211 - Snapshot state is unclear when custom viewing several snapshots
Summary: Snapshot state is unclear when custom viewing several snapshots
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 15:50 UTC by Ori Gofen
Modified: 2016-02-10 18:10 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.0_rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 07:53:28 UTC
oVirt Team: Storage


Attachments (Terms of Use)
images (63.24 KB, patch)
2014-08-03 15:50 UTC, Ori Gofen
no flags Details | Diff
screenshots (63.24 KB, application/octet-stream)
2014-08-05 05:10 UTC, Allon Mureinik
no flags Details
snapshot_preview_disks (37.13 KB, image/png)
2014-08-05 13:14 UTC, Daniel Erez
no flags Details
mockup: suggested improvement (23.50 KB, image/png)
2014-08-05 13:23 UTC, Einav Cohen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32576 master MERGED webadmin: snapshot preview - display entities in description Never
oVirt gerrit 32754 ovirt-engine-3.5 MERGED webadmin: snapshot preview - display entities in description Never

Description Ori Gofen 2014-08-03 15:50:20 UTC
Created attachment 923636 [details]
images

Description of problem:

when viewing several snapshots via snapshot overview (see image)
UI displays only one snapshot as being previewed (the one with "VM CONFIGURATION=1")

Version-Release number of selected component (if applicable):
beta.2

How reproducible:
100%

Steps to Reproduce:
1.view snapshots via snapshot overview

Actual results:
only one snapshot is marked as being viewed

Expected results:
one should expect to see all previewed items status aligned 

Additional info:

Comment 1 Liz 2014-08-04 18:07:42 UTC
Ori - It doesn't look like the attachment is working, would you mind reattaching?

Thanks,
Liz

Comment 2 Allon Mureinik 2014-08-05 05:10:17 UTC
Created attachment 924079 [details]
screenshots

Comment 3 Allon Mureinik 2014-08-05 05:11:35 UTC
Seems as though the attachment is OK, is was just uploaded with the wrong mime type (patch instead of zip), so bugzilla doesn't recognize it properly.
Re-uploaded.

Comment 4 Daniel Erez 2014-08-05 13:13:36 UTC
Hi Liz,

iiuc, the issue here is in the indication of disks that are currently being previewed. Currently, a previewed snapshot can be identified by the 'Preview Mode' string under its description. In case of custom preview, that string is added to the VM configuration snapshot while the selected disks can be viewed under disks tab. To improve/clarify the UX, perhaps we can add a similar indication for disks under snapshots tab? I.e. something like adding a list of previewed disks under snapshot description? [Attached is a mock-up for illustration]

Comment 5 Daniel Erez 2014-08-05 13:14:19 UTC
Created attachment 924213 [details]
snapshot_preview_disks

Comment 6 Einav Cohen 2014-08-05 13:23:27 UTC
Created attachment 924215 [details]
mockup: suggested improvement

Comment 7 Einav Cohen 2014-08-05 13:25:43 UTC
ok, I just uploaded attachment 924215 [details] without noticing that Daniel has uploaded a solution a couple of minutes before that. :)
all in all, the solutions are pretty similar - I am not sure whether we should display "OK", "In Preview" or something else for the snapshot's status for which Disks are previewed. not critical though.

Comment 8 Liz 2014-08-05 16:10:06 UTC
@Daniel - This make complete sense to me to allow for this same detail to be available to the user in the Snapshots tab after the user has selected a specific VM. Reusing the exact same column title and row styling makes most sense to me. Thanks for the extra clarification on this.

Best,
Liz

Comment 9 Ori Gofen 2014-09-14 15:37:43 UTC
is this should be fixed on vt3.1 build? because it isn't

Comment 10 Ori Gofen 2014-09-15 09:47:31 UTC
After discussion with derez,the fix is not yet merged.
returning to modify

Comment 11 Allon Mureinik 2014-09-15 12:32:57 UTC
This is an oVrit bug, with a fix included in ovirt-3.5.0_rc2, and thus must be ON_QA.
The fact that it's not included in any RHEVM build yet is inconsequential.


Note You need to log in before you can comment on or make changes to this bug.