Bug 1126222 - Rubygem-staypuft:[RFE] Create log-collector-tool or a central location to allow to find all staypuft relevant logs in case the deployment fails.
Summary: Rubygem-staypuft:[RFE] Create log-collector-tool or a central location to al...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL: https://trello.com/c/aVrBYOI1/164-cen...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-03 17:49 UTC by Omri Hochman
Modified: 2015-04-29 14:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 14:49:04 UTC


Attachments (Terms of Use)

Description Omri Hochman 2014-08-03 17:49:47 UTC
Rubygem-staypuft:[RFE]  Create log-collector-tool or a central location to allow to find all staypuft relevant logs in case the deployment fails. 

Environment:
------------
ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch
puppet-3.6.2-1.1.el6.noarch
puppet-server-3.6.2-1.1.el6.noarch
openstack-puppet-modules-2014.1-19.9.el6ost.noarch
foreman-1.6.0.21-2.el6sat.noarch


Description: 
------------
In case deployment fails in order to debug the root cause of the failure,
most of the time, the user will have to ssh or connect via console to  discovered-hosts that were involved in the deployment. - the user will have to check the puppet logs under /var/log/messages.  besides that some times the Error will be found in foreman's logs like production.log . 
We should have a log-collector-tool or to one central location that will allow to find all relevant staypuft logs in case the deployment fails.


Note You need to log in before you can comment on or make changes to this bug.