Bug 1126255 - The result of modinfo are different on RHEL6 and RHEL7 about kernel module with extension ".o".
Summary: The result of modinfo are different on RHEL6 and RHEL7 about kernel module wi...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Shea
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 01:49 UTC by emily wang
Modified: 2014-08-06 17:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 17:25:47 UTC


Attachments (Terms of Use)

Description emily wang 2014-08-04 01:49:08 UTC
Description of problem:

I have a kernel module with the extension ".o" instead of ".ko", and bud cannot get the description with the command of modinfo on RHEL7.

But on RHEL6, I can get the correct information with the extension ".o".

In addition, I change the module name with the extension ".ko", then I can get information again on RHEL7.

Version-Release number of selected component (if applicable):
[root@localhost ~]# modinfo -V
kmod version 14

How reproducible:
always

Steps to Reproduce:
1.modinfo splxmod-3.10.0-123.el7.x86_64.x86_64.o

Actual results:
modinfo: ERROR: Module splxmod-3.10.0-123.el7.x86_64.x86_64.o not found.

Expected results:
license:        GPL
description:    Kernel Hooking Module for ServerProtect for Linux (User Build) 
		version 3.0.1.0012      2014-08-04   09:04:54
		Red Hat(TM) Enterprise Linux Server/Client 7 X86_64
author:         Trend Micro ServerProtect for Linux User
srcversion:     1E656C9459DBC67CF803231

Additional info:

Comment 2 David Shea 2014-08-06 17:04:34 UTC
modinfo from module-init-tools in RHEL 6 accepted modules with .o extensions since it contained support for older 2.4 kernel modules. RHEL 7 has migrated to kmod for module support, and kmod only supports kernel versions 2.6 and newer. Kernel modules with .o extensions have not been used by the linux kernel since Linux 2.4.

Comment 3 RHEL Product and Program Management 2014-08-06 17:25:47 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.