Bug 1126318 - RHEL 6 clients content view can not be changed: access to repomd.xml fails with [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"
Summary: RHEL 6 clients content view can not be changed: access to repomd.xml fails wi...
Keywords:
Status: CLOSED DUPLICATE of bug 1112833
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Linux
unspecified
urgent vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 07:39 UTC by Sebastian Hetze
Modified: 2014-08-04 15:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 15:03:15 UTC


Attachments (Terms of Use)
output of: grep subscription-manager /var/log/messages (1.44 KB, application/x-gzip)
2014-08-04 10:00 UTC, Sebastian Hetze
no flags Details
/etc/yum.repos.d/redhat.repo from RHEL 6.5 client (2.88 KB, text/plain)
2014-08-04 10:01 UTC, Sebastian Hetze
no flags Details
The tarball from running `foreman-debug` on Sat6 server (450.65 KB, application/x-xz)
2014-08-04 10:02 UTC, Sebastian Hetze
no flags Details
Foreman and httpd logs during CV change, subscription-manager refresh and yum list (6.15 KB, application/x-tar)
2014-08-04 14:45 UTC, Sebastian Hetze
no flags Details

Description Sebastian Hetze 2014-08-04 07:39:23 UTC
Description of problem:

After changing the Content View for a RHEL 6.5 Content Host in Satellite 6.0.3 all attempts to access repomd.xml fail with [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"

Version-Release number of selected component (if applicable):
Satellite 6.0.3, RHEL 6.5 Content Host

Steps to Reproduce:
1. Create or register RHEL 6.5 Content Host in Satellite-6
2. Create new Content View for RHEL 6.5 Operating System
3. In "Content Hosts" select above created RHEL 6.5 host, edit Content View and select above created view
4. On RHEL 6.5 host perform "subscription-manager refresh"
5. On RHEL 6.5 host perform "yum repolist"

Actual results:

yum gives error message:

This system is receiving updates from Red Hat Subscription Management.
https://satellite6.example.com/pulp/repos/MyOrg/Library/NewView/content/dist/rhel/server/6/6Server/x86_64/optional/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403 Forbidden"

Expected results:

yum should load repomd.xml from all subscribed channels

Additional info:

For RHEL 7 hosts changing of Content View works.

Comment 1 RHEL Product and Program Management 2014-08-04 07:43:51 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Stephen Benjamin 2014-08-04 09:05:28 UTC
What's the status of the subscription inside the UI? Is it green or red? After a Content View change, you probably need to re-assign a subscription either by clicking 'Run auto attach' on the Subscription tab or doing it manually.

If you still have the issue after assinging a subscription and running 'subscription-manager refresh':


Can you run on the client:

subscription-manager status
subscription-manager list
subscription-manager repos

And attach:

From the client:
- /etc/yum.repos.d/redhat.repo
- output of: grep subscription-manager /var/log/messages

From Satellite:
- The tarball from running `foreman-debug`

Comment 4 Sebastian Hetze 2014-08-04 10:00:49 UTC
Created attachment 923832 [details]
output of: grep subscription-manager /var/log/messages

Comment 5 Sebastian Hetze 2014-08-04 10:01:42 UTC
Created attachment 923833 [details]
/etc/yum.repos.d/redhat.repo from RHEL 6.5 client

Comment 6 Sebastian Hetze 2014-08-04 10:02:42 UTC
Created attachment 923834 [details]
The tarball from running `foreman-debug` on Sat6 server

Comment 7 Sebastian Hetze 2014-08-04 10:05:25 UTC
RHEL 6.5 host is in auto-attach mode, subscription status is green before issuing the refresh.

[root@rhel6-test01 ~]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Current

[root@rhel6-test01 ~]# subscription-manager list
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        6.5
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         02/13/14
Ends:           02/13/15

[root@rhel6-test01 ~]# subscription-manager repos
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-6-server-rpms
Repo Name: Red Hat Enterprise Linux 6 Server (RPMs)
Repo URL:  https://satellite6.lunetix.de/pulp/repos/LunetIX/Library/RHEL6_L_G/content/dist/rhel/server/6/$releasever/$basearch/
           os
Enabled:   1

Repo ID:   rhel-6-server-extras-rpms
Repo Name: Red Hat Enterprise Linux 6 Server - Extras (RPMs)
Repo URL:  https://satellite6.lunetix.de/pulp/repos/LunetIX/Library/RHEL6_L_G/content/dist/rhel/server/6/6Server/$basearch/extr
           as/os
Enabled:   0

Repo ID:   rhel-6-server-optional-rpms
Repo Name: Red Hat Enterprise Linux 6 Server - Optional (RPMs)
Repo URL:  https://satellite6.lunetix.de/pulp/repos/LunetIX/Library/RHEL6_L_G/content/dist/rhel/server/6/$releasever/$basearch/
           optional/os
Enabled:   1

Repo ID:   rhel-6-server-supplementary-rpms
Repo Name: Red Hat Enterprise Linux 6 Server - Supplementary (RPMs)
Repo URL:  https://satellite6.lunetix.de/pulp/repos/LunetIX/Library/RHEL6_L_G/content/dist/rhel/server/6/$releasever/$basearch/
           supplementary/os
Enabled:   0

Repo ID:   rhel-6-server-rh-common-rpms
Repo Name: Red Hat Enterprise Linux 6 Server - RH Common (RPMs)
Repo URL:  https://satellite6.lunetix.de/pulp/repos/LunetIX/Library/RHEL6_L_G/content/dist/rhel/server/6/$releasever/$basearch/
           rh-common/os
Enabled:   0

Comment 8 Sebastian Hetze 2014-08-04 14:45:16 UTC
Created attachment 923898 [details]
Foreman and httpd logs during CV change, subscription-manager refresh and yum list

Comment 9 Justin Sherrill 2014-08-04 15:03:15 UTC

*** This bug has been marked as a duplicate of bug 1112833 ***


Note You need to log in before you can comment on or make changes to this bug.