Bug 1126331 - mkfs.ext4 fails and crashes system [NEEDINFO]
Summary: mkfs.ext4 fails and crashes system
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 08:15 UTC by Will Kemp
Modified: 2014-12-10 15:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-10 15:02:14 UTC
jforbes: needinfo?


Attachments (Terms of Use)
Kernel error messages from mkfs.ext4 (2.49 MB, image/jpeg)
2014-08-04 08:15 UTC, Will Kemp
no flags Details

Description Will Kemp 2014-08-04 08:15:41 UTC
Created attachment 923795 [details]
Kernel error messages from mkfs.ext4

Description of problem:
I'm trying to make an ext4 filesystem on a Seagate 1TB external hdd. After the "Writing superblocks ...." message, it says "Warning, had trouble writing out superblocks." Then many screens full of error messages are output to the console including lines saying:

sd 6:0:0:0: [sdc] Unhandled error code.
Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK

(see attached photo)

and then the kernel crashes. I haven't managed to get information from the crash.

I tried a few times and had to give up. Later, I tried the same thing on a Ubuntu system and it worked with no problems.


Version-Release number of selected component (if applicable):

3.15.7-200.fc20.x86_64
and
3.15.6-200.fc20.x86_64

How reproducible:
Happens every time for me

Steps to Reproduce:
1. Plug in 1TB Seagate external hdd
2. mkfs -t ext4 /dev/sdc1
3. system crashes

Actual results:
mkfs fails and system crashes

Expected results:
mkfs succeeds

Additional info:
Samsung 13.3 series 5 Ultrabook

Comment 1 Justin M. Forbes 2014-11-13 16:03:07 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.

Comment 2 Justin M. Forbes 2014-12-10 15:02:14 UTC
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in over 3 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.


Note You need to log in before you can comment on or make changes to this bug.