Bug 1126387 - incorrect (non standard )red error on content page while installing new war on top of existing
Summary: incorrect (non standard )red error on content page while installing new war o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Content
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER03
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 10:10 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:00:20 UTC
Type: Bug


Attachments (Terms of Use)
deploy_from_repo (222.08 KB, image/png)
2014-08-04 10:10 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-08-04 10:10:44 UTC
Created attachment 923837 [details]
deploy_from_repo

Description of problem:
incorrect (non standard) red error on content page while installing new war on top of existing 

Version-Release number of selected component (if applicable):
JON 3.3

How reproducible:
always

Steps to Reproduce:
1.  Start JBoss EAP 6.1 standalone server.
2.  Start JBoss ON 3.2 system.
3.  Import JBoss EAP server into inventory.
4.  Configure connection settings for newly imported resource.
5.  Deploy jboss-as-helloworld.war to JBoss EAP server.

6.  Create test repository from Administration > Content / Repositories:

    *   *Name*: `Test Repo`

7.  From Test Repo upload a new version of helloworld WAR:

    *   *Upload File*:  jboss-as-helloworld-1.0.1.war (any WAR will do)
    *   *Type*: *File [Deployment:JBossAS7]*

8.  Subscribe the imported JBoss EAP server to *Test Repo*:
    
    1.  Under *Resources Subscribed To This Repository* click *SUBSCRIBE...* button.
    2.  For search, enter `jboss-as-helloworld.war` and set type drop-down to *Service* and click search.
    3.  Check jboss-as-helloworld.war resource which was returned.
    4.  Click *SUBSCRIBE SELECTED*.
    
9.  Navigate to the content page of the jboss-as-helloworld.war resource.
10. Select the Subscription tab.
11. Click on *Test Repo* and navigate to repository page
12. Select new war and click install

Actual results:
incorrect red error message is visible on subscriptions page


Expected results:
ether war should be updated OR meaningful error message should be visible, telling that the new war cannot be installed unless it has the same version as the old one.


Additional info:
screen-shot attached

Comment 2 Armine Hovsepyan 2014-09-18 15:33:31 UTC
Unable to reproduce in JON 3.3 ER03 
marking as verified


Note You need to log in before you can comment on or make changes to this bug.