Bug 1126391 - [test plan] Import plan's document to same content, system will insert a new version for document.
Summary: [test plan] Import plan's document to same content, system will insert a new ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: TCMS
Classification: Other
Component: Application
Version: 3.8.10
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Xu Lei
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 10:23 UTC by yangqiu
Modified: 2016-02-22 00:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 10:21:07 UTC


Attachments (Terms of Use)
[test plan] Import plan's document to same value, system will insert a new version for document. (169.08 KB, image/jpeg)
2014-08-04 10:23 UTC, yangqiu
no flags Details

Description yangqiu 2014-08-04 10:23:00 UTC
Created attachment 923839 [details]
[test plan] Import plan's document to same value, system will insert a new version for document.

Description of problem:
as summary.

Version-Release number of selected component (if applicable):
v3.8.10-1 on devel server.

How reproducible:
100%

Steps to Reproduce:
1.Create a plan with document like 'text plan 1 - document'
2.Edit this plan, import the plan's document from odt file, and the file content is the same as the old document like 'text plan 1 - document'
3.Enter plan's document history page, inspect how many versions for this plan.
https://tcms-devel.app.eng.nay.redhat.com/plan/10138/history/

Actual results:
There are 2 versions for this plan.

Expected results:
There is only 1 version for this plan, because the content for plan's document does not change.

Additional info:

Comment 1 Xu Lei 2014-08-05 07:51:24 UTC
verified, odt document will append some characters around the text, just like <p></p>, all of this will be the whole plan text to do check sum.

so if you type "abc" in web ui, it means <p>abc</p> in database.
and type "abc" in odt, it means <p class="ODT P1">abc</p>, they are different.


we can not remove the element just like <p> because it control the style that plan texts are shown in web ui.

I think it's acceptable.

Comment 2 yangqiu 2014-08-11 10:21:07 UTC
confirm with dev, the above issue does not happened when import different files with same format, so close the issue.


Note You need to log in before you can comment on or make changes to this bug.