Bug 1126416 - perl-MooseX-Role-WithOverloading and perl-MooseX-Role-Parameterized conflicts on /usr/share/man/man3/MooseX::Role::README.3pm.gz
Summary: perl-MooseX-Role-WithOverloading and perl-MooseX-Role-Parameterized conflicts...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-MooseX-Role-Parameterized
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Iain Arnell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 11:56 UTC by Petr Pisar
Modified: 2014-08-05 11:10 UTC (History)
4 users (show)

Fixed In Version: perl-MooseX-Role-Parameterized-1.05-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 11:10:45 UTC


Attachments (Terms of Use)

Description Petr Pisar 2014-08-04 11:56:47 UTC
# repoquery --whatprovides /usr/share/man/man3/MooseX::Role::README.3pm.gz
perl-MooseX-Role-WithOverloading-0:0.14-1.fc22.x86_64
perl-MooseX-Role-Parameterized-0:1.05-1.fc22.noarch

This conflicts prevents from installing both packages at the same time what's needed for building perl-CatalystX-Profile <http://koji.fedoraproject.org/koji/taskinfo?taskID=7233277>.

This is caused by ./README.pod file in both distribution which gets installed by the Makefile.PL into the same location. I don't know if this bug or feature of ExtUtils::MakeMaker or distzilla or what.

Comment 1 Petr Pisar 2014-08-04 12:01:10 UTC
Paul, that where your upgrades.

Comment 2 Paul Howarth 2014-08-04 12:38:48 UTC
I think upstream is generating manpages with the wrong filenames:

https://github.com/moose/MooseX-Role-WithOverloading/issues/3

If there's no quick fix from upstream, I'll exclude the files.

Comment 3 Paul Howarth 2014-08-05 11:10:45 UTC
Punted to EU::MM upstream, looks like the conflicting files shouldn't be installed at all.

https://github.com/Perl-Toolchain-Gang/ExtUtils-MakeMaker/issues/119

Bearing that in mind, I've removed the conflicting files from the packages.


Note You need to log in before you can comment on or make changes to this bug.