Bug 1126479 - vim <directory> just displays empty file if absolute path given
Summary: vim <directory> just displays empty file if absolute path given
Keywords:
Status: CLOSED DUPLICATE of bug 1176367
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vim
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 14:12 UTC by Martin Frodl
Modified: 2015-03-03 10:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-03 10:55:11 UTC


Attachments (Terms of Use)

Description Martin Frodl 2014-08-04 14:12:04 UTC
Description of problem:

Directory listing with vim does not work when an absolute path is given; an empty file is displayed by vim instead. This problem does not happen if the directory is specified by a relative path.

Version-Release number of selected component (if applicable):
vim-enhanced-7.4.160-1.el7.ppc64

How reproducible:
100%

Steps to Reproduce:
(1) mkdir -p /tmp/vimtest/subdir
(2) vim /tmp/vimtest/subdir
(3) cd /tmp
(4) vim vimtest
(5) cd /tmp/vimtest
(6) vim .
(7) cd subdir
(8) vim ..

Actual results:
ad (2)       Displays an empty file
ad (4,6,8)   Displays directory listing of /tmp/vimtest

Expected results:
ad (2,4,6,8) Displays directory listing of /tmp/vimtest

Additional info:
This behaviour does not take place on RHEL 5 & 6.

Comment 2 Karsten Hopp 2015-03-03 10:55:11 UTC

*** This bug has been marked as a duplicate of bug 1176367 ***


Note You need to log in before you can comment on or make changes to this bug.