Bug 11265 - v6.2 with 2.2.14-12smp crashes on Supermicro P6DGU motherboard
v6.2 with 2.2.14-12smp crashes on Supermicro P6DGU motherboard
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-06 14:10 EDT by admin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-07 17:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description admin 2000-05-06 14:10:55 EDT
Hardware

Supermicro P6DGU running dual Intel Pentium III 650 (slot 1)
Adaptec AIC 7890 onboard controller
Two SCSI hard drives
64 Mbyte 100Mhz memory

Problem

Upgraded from 6.1 to 6.2.  Runs both 2.2.14-5.0 and 2.2.14-5.0smp
kernels OK.

Installed 2.2.14-12 and 2.2.14-12smp and the smp will not boot.

Stops shortly after cdrom detection.....

"/lib/aic7xxxx.0: unresolved symbol......
/lib/aic7xxxx.0: unresolved symbol......
/lib/aic7xxxx.0: unresolved symbol......
/lib/aic7xxxx.0: unresolved symbol......
/lib/aic7xxxx.0: unresolved symbol......
etc

autodetecting RAID arrays...
autorun.....
.....autorun DONE
kmod failed to exec /sbin/modprobe
  -s -k block-major-8 errno = 2
VFS: cannot open root device 08:08

kernel panic VFS unable to mount root fs on 08:08"
Comment 1 Doug Ledford 2000-05-07 17:44:59 EDT
Your UP and SMP kernel images are trying to use the same initrd image to load
their respective modules (or else you made the initrd image for the SMP kernel
without giving the proper kernel version parameter).  When making the initrd
images for the two kernels it should be:

mkinitrd /boot/initrd-2.2.14-12.img 2.2.14-12
mkinitrd /boot/initrd-2.2.14-12smp.img 2.2.14-12smp

and then you need to make sure the kernel image sections of /etc/lilo.conf match
the proper kernel to the proper initrd images before rerunning lilo.
Comment 2 admin 2000-05-08 06:21:59 EDT
Yes the problem was an error in the /etc/lilo.conf file

image=/boot/vmlinuz-2.2.14-12 rather than image=/boot/vmlinuz-2.2.14-12smp

Note You need to log in before you can comment on or make changes to this bug.