Bug 1126588 - Anaconda uses sha1 instead of sha2 hashes
Summary: Anaconda uses sha1 instead of sha2 hashes
Keywords:
Status: CLOSED DUPLICATE of bug 1096530
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 20:42 UTC by dcomrie
Modified: 2014-08-04 20:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 20:45:07 UTC


Attachments (Terms of Use)

Description dcomrie 2014-08-04 20:42:58 UTC
Description of problem:

Anaconda is using sha1 hashes instead of the more secure sha2.

Version-Release number of selected component (if applicable):

The version that is shipped with the Fedora 20 iso.

How reproducible:

Very.

Steps to Reproduce:
1.Run anaconda
2.Install with LVM/LUKS
3.do a luksDump on the encrypted partition

Actual results:

Version:        1
Cipher name:    aes
Cipher mode:    xts-plain64
Hash spec:      sha1
Payload offset: 4096
MK bits:        512

Expected results:

Version:        1
Cipher name:    aes
Cipher mode:    xts-plain64
Hash spec:      sha256 <-- or sha512
Payload offset: 4096
MK bits:        512


Additional info:

Comment 1 David Shea 2014-08-04 20:45:07 UTC

*** This bug has been marked as a duplicate of bug 1096530 ***


Note You need to log in before you can comment on or make changes to this bug.