Bug 1126599 - Add support for configuring SSL for RabbitMQ
Summary: Add support for configuring SSL for RabbitMQ
Keywords:
Status: CLOSED DUPLICATE of bug 1084229
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: Installer
Assignee: Rob Crittenden
QA Contact: Udi
URL: https://trello.com/c/D2SWdilh/131-ssl...
Whiteboard:
Depends On: 1084229 1128170 1141357 1146136
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-04 21:00 UTC by Nathan Kinder
Modified: 2014-10-10 12:49 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1084229
Environment:
Last Closed: 2014-10-10 12:49:55 UTC


Attachments (Terms of Use)

Description Nathan Kinder 2014-08-04 21:00:41 UTC
+++ This bug was initially created as a clone of Bug #1084229 +++

With the switch from Qpid to RabbitMQ, we need to add support for configuring RabbitMQ for SSL/TLS in the Foreman installer.  This might require changes to the puppet modules as well, which will need to be determined when we start working on this.

--- Additional comment from Rob Crittenden on 2014-04-08 10:40:09 EDT ---

The openstack-puppet-modules is using this upstream commit, https://github.com/puppetlabs/puppetlabs-rabbitmq/tree/015bd788ccb495051a2db48e344a3a6aa3381076

Based on a reading of this we should be good puppet-wise for this upstream module. Changes in the controller module will be required to configure rabbitmq instead, with the biggest change switching from NSS to OpenSSL for the certificate tracking when freeipa == True.

Comment 2 Rob Crittenden 2014-09-23 15:16:19 UTC
Haven't tested it yet but I may need to pull in this fix as well which ties kombu_* to rabbit_use_ssl: https://bugs.launchpad.net/puppet-neutron/+bug/1356083

Comment 3 Mike Burns 2014-10-10 12:49:55 UTC
openstack-foreman-installer only needs 1 bug for tracking this issue, closing as a duplicate

*** This bug has been marked as a duplicate of bug 1084229 ***


Note You need to log in before you can comment on or make changes to this bug.