Bug 112671 - xinetd takes all cpu resources
xinetd takes all cpu resources
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-27 07:50 EST by Heinz Ruffieux
Modified: 2014-08-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 15:15:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heinz Ruffieux 2003-12-27 07:50:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2.1)
Gecko/20030225

Description of problem:
When starting xinetd using command "/etc/rc.d/init.d/xinetd start"
xinetd works fine, but takes all cpu resources (checked with command:
top).

Content of /etc/xinetd.conf file:

#
# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/
                                                                     
          
defaults
{
        instances               = 60
        log_type                = SYSLOG authpriv
        log_on_success          = HOST PID
        log_on_failure          = HOST
        cps                     = 25 30
}
                                                                     
          
includedir /etc/xinetd.d



Version-Release number of selected component (if applicable):
xinetd-2.3.11-1.8.0

How reproducible:
Always

Steps to Reproduce:
1. start xinetd
2.
3.
    

Actual Results:  xinet works, but takes all cpu resources

Expected Results:  work but using minimal cpu resources

Additional info:
Comment 1 Steve Grubb 2005-03-22 14:02:18 EST
I'm the upstream maintainer of Xinetd. Does xinetd still do this? Did you have
any services using xinetd such as sgi_fam? Send xinetd a SIGUSR1 to get it to
dump its state. Look for the file /var/run/xinetd.dump and attach it.

If this is not reproducible, I'd say this could be closed as not a bug.

Note You need to log in before you can comment on or make changes to this bug.