Bug 1126720 - SMB:Yum update of samba packages leads to dependency error as RHEL has higher version of samba
Summary: SMB:Yum update of samba packages leads to dependency error as RHEL has higher...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: RHGS 3.0.0
Assignee: Jose A. Rivera
QA Contact: surabhi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 06:56 UTC by surabhi
Modified: 2015-05-15 17:43 UTC (History)
6 users (show)

Fixed In Version: samba-3.6.9-169.1.el6rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 19:45:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 23:26:55 UTC

Description surabhi 2014-08-05 06:56:31 UTC
Description of problem:
While doing yum update,hitting dependency errors for samba packages.Again the issue is that RHEL channel has version samba-3.6.9-169.el6_5 and RHS has samba package version 3.6.9-168.4.el6rhs.

We need to fix this issue for long term as we keep facing the problem as soon as RHEL releases new samba package.

Version-Release number of selected component (if applicable):
 rpm -qa | grep samba
samba-3.6.9-168.4.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Do yum update for RHS/Samba packages



Actual results:
Yum update fails with following errors:

-> Running transaction check
---> Package samba.x86_64 0:3.6.9-168.4.el6rhs will be updated
--> Processing Dependency: samba = 3.6.9-168.4.el6rhs for package: samba-glusterfs-3.6.9-168.4.el6rhs.x86_64
--> Processing Dependency: samba = 3.6.9-168.4.el6rhs for package: samba-swat-3.6.9-168.4.el6rhs.x86_64
---> Package samba.x86_64 0:3.6.9-169.el6_5 will be an update
--> Processing Dependency: samba-winbind-clients = 3.6.9-169.el6_5 for package: samba-3.6.9-169.el6_5.x86_64
--> Processing Dependency: samba-common = 3.6.9-169.el6_5 for package: samba-3.6.9-169.el6_5.x86_64
--> Running transaction check
         Removing: samba-winbind-3.6.9-168.4.el6rhs.x86_64 (@rhs3.0-samba-server)
               samba-winbind = 3.6.9-168.4.el6rhs
           Updated By: samba-winbind-3.6.9-169.el6_5.x86_64 (rhel-x86_64-server-6)
               samba-winbind = 3.6.9-169.el6_5

Error: Package: samba-glusterfs-3.6.9-168.4.el6rhs.x86_64 (@rhs3.0-samba-server)
           Requires: libsmbclient = 3.6.9-168.4.el6rhs
           Removing: libsmbclient-3.6.9-168.4.el6rhs.x86_64 (@rhs3.0-samba-server)
               libsmbclient = 3.6.9-168.4.el6rhs
           Updated By: libsmbclient-3.6.9-169.el6_5.x86_64 (rhel-x86_64-server-6)
               libsmbclient = 3.6.9-169.el6_5
           Available: libsmbclient-3.5.4-68.el6.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.4-68.el6
           Available: libsmbclient-3.5.4-68.el6_0.1.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.4-68.el6_0.1
           Available: libsmbclient-3.5.4-68.el6_0.2.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.4-68.el6_0.2
           Available: libsmbclient-3.5.6-86.el6.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.6-86.el6
           Available: libsmbclient-3.5.6-86.el6_1.4.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.6-86.el6_1.4
           Available: libsmbclient-3.5.10-114.el6.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.10-114.el6
           Available: libsmbclient-3.5.10-115.el6_2.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.10-115.el6_2
           Available: libsmbclient-3.5.10-116.el6_2.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.10-116.el6_2
           Available: libsmbclient-3.5.10-125.el6.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.5.10-125.el6
           Available: libsmbclient-3.6.9-151.el6.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.6.9-151.el6
           Available: libsmbclient-3.6.9-151.el6_4.1.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.6.9-151.el6_4.1
           Available: libsmbclient-3.6.9-164.el6.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.6.9-164.el6
           Available: libsmbclient-3.6.9-167.el6_5.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.6.9-167.el6_5
           Available: libsmbclient-3.6.9-168.el6_5.i686 (rhel-x86_64-server-6)
               libsmbclient = 3.6.9-168.el6_5


Expected results:
Update should not have any errors.

Additional info:
We need a rebase of RHS samba package from 168 to 169 or some higher version so we don't hit this issue with release of Denali.As we might face it again once RHEL has another version of Samba package released.

Comment 1 Raghavendra Talur 2014-08-05 12:35:49 UTC
https://brewweb.devel.redhat.com/buildinfo?buildID=364118 is the build which is an update for our build of samba.

Comment 3 Jose A. Rivera 2014-08-07 12:25:52 UTC
New Samba build to match the conflicting RHEL Samba build.

https://brewweb.devel.redhat.com/buildinfo?buildID=374876

Comment 4 surabhi 2014-08-11 06:14:11 UTC
Doing yum update, updates the version of samba to the latest one samba-3.6.9-169.1.el6rhs.x86_64 and didn't see any conflicts or dependency issues.If there will be any other release of samba from RHEL , will have to follow that and provide updates accordingly.
Marking this BZ verified.

Comment 6 errata-xmlrpc 2014-09-22 19:45:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html


Note You need to log in before you can comment on or make changes to this bug.