Bug 1126787 - Alert is not firing and throws SQL exception while executing alert definition
Summary: Alert is not firing and throws SQL exception while executing alert definition
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring - Alerts
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: DR02
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 09:40 UTC by Jeeva Kandasamy
Modified: 2014-08-20 07:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 07:22:21 UTC
Type: Bug


Attachments (Terms of Use)
attached server.log (360.27 KB, text/x-log)
2014-08-05 09:40 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-08-05 09:40:48 UTC
Created attachment 924158 [details]
attached server.log

Description of problem:
Alert is not firing and throws SQL exception while executing alert definition

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version : 3.3.0.DR01
Build Number : 6468454:dda0a47
GWT Version : 2.5.0
SmartGWT Version : 3.0p


How reproducible:
always

Steps to Reproduce:
1. Login in to JON GUI with admin role
2. Import RHQ Agent resource
3. Navigate to 'Inventory->Servers->RHQ Agent->Monitoring->Schedules'
4. Enable, 'JVM Free Memory' and 'JVM Total Memory'
5. Navigate to 'Inventory->Servers->RHQ Agent->Alerts->Definitions'
6. Create a definition with 'JVM Free Memory' or 'JVM Total Memory', Definition should easily triggered condition. (Example: condition: JVM Total Memory > 2MB) and configure 'Notification' to system user, 'Recovery: Disabled when fired: yes', 'Dampening: Consecutive:1'
7. This alert definition never trigger
8. Throws SQL exception while executing this definition.
9. Whenever navigate to alert definition page, throws exception.

Actual results:
Throws SQL exception and alert definition is not firing,
05:34:00,852 ERROR [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] (Thread-9 (HornetQ-client-global-threads-1336003341)) Batch entry 0 update RHQ_ALERT_DEFINITION set DAMPENING_CATEGORY='1', DAMPENING_PERIOD=0, DAMPENING_PERIOD_UNITS=NULL, DAMPENING_VALUE=1, DAMPENING_VALUE_UNITS=NULL, REQUIRED='0', CONTROL_FILTERED='0', CTIME=1407230799952, DELETED='0', DESCRIPTION='', ENABLED='0', RESOURCE_GROUP_ID=NULL, GROUP_ALERT_DEF_ID=NULL, MTIME=1407231210849, NAME='Alert JVM total Size', NOTIFY_FILTERED='0', PARENT_ID=0, PRIORITY='MEDIUM', READ_ONLY='0', RECOVERY_ID=0, RESOURCE_ID=10003, RESOURCE_TYPE_ID=NULL, WILL_RECOVER='1' where ID=10031 was aborted.  Call getNextException to see the cause.


Expected results:
Should not throw any exception and should fired if it meets the condition.


Additional info: server.log is attached.

Comment 1 Michael Burman 2014-08-13 10:23:45 UTC
Are you sure the instance in question has been in good health? The symptoms (and based on the log) indicate that there's something wrong with the connection between JON <-> Postgres (unfortunately the log doesn't show more, the real reason is hidden from that stacktrace).

I also tried to replicate this and I wasn't successful.

Comment 3 Jeeva Kandasamy 2014-08-20 07:22:21 UTC
Michael, I destroyed the machine where I faced the issue.

I tested this with JON 3.3.0 ER01 and I'm unable to reproduce this issue. Hence I'm moving this issue to CLOSED/NOTABUG state.

Version: 
JBoss Operations Network
Version : 3.3.0.ER01
Build Number : 23b3476:f3aa7e7
GWT Version : 2.5.0
SmartGWT Version : 3.0p


Note You need to log in before you can comment on or make changes to this bug.