Bug 112689 - Cannot Compile Kernel linux-2.4.22-1.2135.nptl
Cannot Compile Kernel linux-2.4.22-1.2135.nptl
Status: CLOSED DUPLICATE of bug 105978
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-12-28 08:53 EST by Yousef Ourabi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Yousef Ourabi 2003-12-28 08:53:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.cd /usr/src/linux-2.4
2.make mrproper && make menuconfig && make dep --> make bzImage
3.I tried repeating steps 1 and 2 after doing export CC=gcc32, however
this had no effect.

Actual Results:  After attempting to compile the kernel I get the
following error message
kernel/kernel.o(.text+0x108c): In function `schedule':
: undefined reference to `active_load_balance'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2135.nptl'
make: *** [vmlinux] Error 2

Expected Results:  Expected Results??? ...Well a brand new shiney
kernel would be nice...

Additional info:

I tried export CC=gcc32, I read in another bugzilla case that this
"bug" of compiling the kernel with another version of GCC was
intentional, if it was may I ask why?
Comment 1 Josh Boyer 2004-01-09 15:21:44 EST
this bug has been around for a long time.  see bug 105978
Comment 2 Dave Jones 2004-01-09 15:49:48 EST

*** This bug has been marked as a duplicate of 105978 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.