Bug 1126952 - ssl framing error on inter-broker connection
Summary: ssl framing error on inter-broker connection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Gordon Sim
QA Contact: Leonid Zhaldybin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 17:13 UTC by Gordon Sim
Modified: 2014-11-09 22:39 UTC (History)
5 users (show)

Fixed In Version: qpid-cpp-0.22-46
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 15:12:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5963 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description Gordon Sim 2014-08-05 17:13:45 UTC
Description of problem:

SSL based interbroker (aka federation) links may fail with framing errors due to incorrect handling of the case where the full protocol header is not received. This is similar to bug 1098545.

Version-Release number of selected component (if applicable):

Qpid 0.28

How reproducible:

Not sure, certainly not 100% repeatable, but reported by one upstream user to be frequently occurring.

Steps to Reproduce:
1. Try to establish interbroker link over ssl

Actual results:

link fails, error on source broker is a decoding error

Expected results:

SSL links work as normal.

Additional info:

Comment 1 Gordon Sim 2014-08-05 20:25:23 UTC
Fixed upstream: https://svn.apache.org/r1615991

Comment 6 Leonid Zhaldybin 2014-08-25 08:42:21 UTC
Tested on RHEL6 (both i386 and x86_64), as well as on RHEL7 builds. This issue has been fixed.

Packages used for testing:

python-qpid-0.22-17
qpid-cpp-0.22-47
qpid-proton-c-0.7-3
qpid-qmf-0.22-38
qpid-tests-0.22-16
qpid-tools-0.22-14

-> VERIFIED

Comment 7 errata-xmlrpc 2014-09-24 15:12:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.