Bug 1127012 - Rubygem-Staypuft: Saving the liveCD to disk doesn't work.
Summary: Rubygem-Staypuft: Saving the liveCD to disk doesn't work.
Keywords:
Status: CLOSED DUPLICATE of bug 1125765
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer LiveCD
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Dan Radez
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-05 22:16 UTC by Alexander Chuzhoy
Modified: 2014-08-08 18:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 13:53:04 UTC


Attachments (Terms of Use)

Description Alexander Chuzhoy 2014-08-05 22:16:18 UTC
Rubygem-Staypuft:  Saving the liveCD to disk doesn't work.

Environment:
rhel-osp-installer-0.1.6-5.el6ost.noarch


How to reproduce:
1. Boot from liveCD and try to change some configuration,
2. Attempt to click the save to disk icon or run the liveinst tool.

Result:
I get the following:
umount: /media/cdtmp.k9lklx: not mounted          
  No volume groups found                          
localuser:root being added to access control list
18:01:34 Starting graphical installation.
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 1036, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 324, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 64, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 308, in __init__
    self.update()
  File "/usr/lib/anaconda/network.py", line 326, in update
    devhash = isys.getDeviceProperties(dev=None)
  File "/usr/lib/anaconda/isys.py", line 376, in getDeviceProperties
    nm = bus.get_object(NM_SERVICE, NM_MANAGER_PATH)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

The image isn't saved and rebooting the machine causes the changes to go away
Expected result:
The image should be saved to disk.

Comment 3 Mike Burns 2014-08-05 23:06:08 UTC
duplicate of bug 1125765

The livecd currently does not support saving runtime configuration to disk.  Any changes made to the image when it's running live are lost.

Comment 5 Mike Burns 2014-08-06 13:53:04 UTC

*** This bug has been marked as a duplicate of bug 1125765 ***


Note You need to log in before you can comment on or make changes to this bug.